1. bdiu's Avatar
    Hi

    I have a unlock 8900 that works fine until last night, which I am unable to make calls nor receive calls. However, I can sms just fine. I am currently with Fido, and the network signal is strong.

    I have tried to reboot my phone, disconnect the network and reconnect, update the new firmware. Nothing works

    I plug the sim card into my other phone, and it's fine. So i am pretty sure it's my phone.

    If anyone is able to help, it would be greatly appreciated.
    03-20-09 11:42 AM
  2. ClintRo's Avatar
    did you do an actual battery pull for 20 seconds... then put it back? or a soft boot?
    03-20-09 12:07 PM
  3. bdiu's Avatar
    I have tried that

    soft boot you mean pressing alt, aA and del? if so, i have done that too.
    03-20-09 12:18 PM
  4. ClintRo's Avatar
    yeah... i figures a battery pull might help... my bad...

    Sorry I am out... will see what I can find!!
    03-20-09 12:21 PM
  5. RLP06's Avatar
    Are people able to call you? what does it say when you try to make a call?
    03-20-09 03:51 PM
  6. bdiu's Avatar
    Thank for the helps guys

    I resolve the problem. Apparently, having name display causes problem with unlocked phone. I went to my cell provider representative, and just so happens she is using the same phone. She told me all i have to do is to disable name display, and it will be fine. And she is right.

    One interesting note, my gf has the same phone and runs into the same problem at the same time. But her phone just magically decides to work again this afternoon. Weird.

    If any of you runs into this situation, try disabling the name display if you have it.

    Hope this helps
    03-20-09 08:10 PM
  7. bdiu's Avatar
    To answer RLP06

    I was unable to make call nor receive call. "Call failed" pops up whenever I tried to call someone.

    very strange.
    03-20-09 08:12 PM
  8. misterjots's Avatar
    Thank for the helps guys

    I resolve the problem. Apparently, having name display causes problem with unlocked phone. I went to my cell provider representative, and just so happens she is using the same phone. She told me all i have to do is to disable name display, and it will be fine. And she is right.

    One interesting note, my gf has the same phone and runs into the same problem at the same time. But her phone just magically decides to work again this afternoon. Weird.

    If any of you runs into this situation, try disabling the name display if you have it.

    Hope this helps
    yeah i think it just happens like your gf it went out then just came back on its own
    03-21-09 02:35 AM
  9. aman089's Avatar
    hey bdiu

    I am also using an unlocked 8900 with fido and i did have the same problem a few weeks ago...i just tried disabling the name display thing and it did work...thanks for the solution!
    03-21-09 04:26 PM
  10. bdiu's Avatar
    No problem =)
    05-23-09 06:41 PM
  11. arthurvanerps's Avatar
    Hello! how do you disable the name display? and what is name display? 'cause i have the same problem!! thanks
    08-15-09 06:53 PM
LINK TO POST COPIED TO CLIPBOARD