1. danielcj's Avatar
    I called the other day to get a code for my 8320. Today I received the email with the unlock code but the email says 'how to unlock your 8100 Pearl'.
    Is this a problem or should I call Tmobile again. I have a feeling that it should work just fine. Here are the instructions:
    1. Press the Menu key.2. Scroll to Options and press the trackball.3. Scroll to Advanced Options and press the trackball.4. Scroll to SIM Card and press the trackball.5. Type MEPPDNote: When typing in MEPPD the letters will not appear on the screen. This step opens up the personalization on the device.6. Press the Alt key and type MEPP2Note: When typing in MEPP2 the letters/number will not appear on the screen. This Step opens up the Enter Network MEP code box.7. Enter unlock code.8. Press the Enter Key.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-19-09 09:53 AM
  2. Sith_Apprentice's Avatar
    it should work with no issues at all provided the code is good
    08-19-09 10:00 AM
  3. larrygump's Avatar
    I guess well find out.....post back and let us know how it worked out!!
    08-19-09 10:15 AM
  4. danielcj's Avatar
    Is there anything I should expect after unlocking? My phone should work just the same right?

    08-19-09 10:57 AM
  5. acegerter's Avatar
    do u have tmobile service?
    Im going to be getting a tmobile BB soon, but I use cingular... will it be awkward for me to call and ask for the unlock code without being a customer?
    08-19-09 02:57 PM
  6. larrygump's Avatar
    nah just call em........tell em u use to be a tmo customer and now your comin over theyll get you one......but you need to do it asap takes at least 24 hours to get it
    08-19-09 04:13 PM
  7. danielcj's Avatar
    So I just unlocked my 8320 using the tmobile code that I was emailed. The instructions were completely useless and incorrect. I had to watch a youtube video to get the right instructions. I can't believe tmobile screwed it up.
    Anyway, the phone is unlocked now and should be fine.
    08-19-09 11:51 PM
  8. joeshmo21's Avatar
    So, I had a Rogers Balckberry in Canada, got it unlocked and am now in the States long term. I threw in my temporary SIM from a pay-as-you-go cell b/c I just can't live without touching my Berry even for a couple of months while I get settled. Problem is it won't let me use the service! I keep getting SOS. What's up? Please help as I'm a newbie with this stuff.
    08-19-09 11:55 PM
  9. jwomack's Avatar
    Try going in and selecting your type of signal! I had to do that when I used a pre-payed att card in my unlocked tmobile 8320

    Posted from my CrackBerry at wapforums.crackberry.com
    08-20-09 12:38 AM