09-02-14 11:06 AM
61 123
tools
  1. cbvinh's Avatar
    Update:

    I received another Unlock Code about 30 minutes ago. It's a completely new set of digits, so I thought I'd try it. I put in a non-T-Mobile SIM (as before) and it successfully unlocked! The SIM is one I had used before. I guess whatever the problem was, they fixed it on their end. Hooray!
    raino likes this.
    08-22-14 02:44 PM
  2. raino's Avatar
    Update:

    I received another Unlock Code about 30 minutes ago. It's a completely new set of digits, so I thought I'd try it. I put in a non-T-Mobile SIM (as before) and it successfully unlocked! The SIM is one I had used before. I guess whatever the problem was, they fixed it on their end. Hooray!
    Completely new set, huh? That's interesting.
    08-22-14 03:10 PM
  3. cbvinh's Avatar
    Completely new set, huh? That's interesting.
    Yeah. Not even close to the original number. I wish there was a way to find out what they did differently.
    08-22-14 05:09 PM
  4. raino's Avatar
    Yeah. Not even close to the original number. I wish there was a way to find out what they did differently.
    Did they get back to you within the quoted time frame? If not, maybe there was some kind of a special escalation involved...
    08-22-14 05:21 PM
  5. cbvinh's Avatar
    Did they get back to you within the quoted time frame? If not, maybe there was some kind of a special escalation involved...
    The last person I spoke to was a BlackBerry specialist and he wanted me to find an active SIM and enter the Unlock Code with it. I was going to spend today finding one, but I received a new Unlock Code via email and tried it. It worked. I went to Live Chat to have a note put with my account to say that the new code worked. Had it not worked, I would have gotten a call from the BlackBerry specialist on Saturday.

    I've been escalated a few times now so someone figured it out and sent the correct code to me, though who, I have no idea. I've had a different specialist each time... at least three.
    08-22-14 08:58 PM
  6. lui22's Avatar
    Are you having the same issue? With the carrier SIM installed, the device says the Unlock Code was successfully entered, but the device is still locked? Without the carrier SIM, the device doesn't accept the Unlock Code as valid and one attempt is lost?
    I'm using an ATT sim that I have for my iPhone. My phone won't unlock to it

    Posted via CB10
    08-24-14 08:39 PM
  7. cbvinh's Avatar
    I'm using an ATT sim that I have for my iPhone. My phone won't unlock to it
    I got a completely different Unlock Code, with the same IMEI, sent to me after escalation. Maybe there was something that was broken and now fixed?
    08-24-14 09:05 PM
  8. lui22's Avatar
    I got a completely different Unlock Code, with the same IMEI, sent to me after escalation. Maybe there was something that was broken and now fixed?
    One of the reasons I'm dome with tmobile is the way they are broken. This is one of them. Coming back from London I'm switching to att or verizon or which ever had the Classic when I come back. If tmobile has the passport though I'd be tempted to stick with them.

    Hopefully they fix your issues because frankly I'm sorry on their behalf

    Posted via CB10
    08-25-14 01:56 AM
  9. cbvinh's Avatar
    Hopefully they fix your issues because frankly I'm sorry on their behalf
    My Q10 is Network Unlocked, ever since they sent me the new Unlock Code. I'm good to go.
    08-25-14 02:15 AM
  10. FishhPoohh's Avatar
    My Tmobile branded BlackBerry Z10 has 17 numbers as well when you enter *#06#

    Still stuck on T-Mobile USA 10.2.1.2228
    09-02-14 10:14 AM
  11. cbvinh's Avatar
    My Tmobile branded BlackBerry Z10 has 17 numbers as well when you enter *#06#
    Yes, 17 digits. Only the first 15 are relevant for unlocking and should match what you would find in Settings->About->Category Hardware.
    09-02-14 11:06 AM
61 123

Similar Threads

  1. Blackberry Q10 Data Plan
    By BigHulkDiesel in forum BlackBerry Q10
    Replies: 6
    Last Post: 08-04-14, 10:43 AM
  2. Sideloaded apps not detecting mobile data connection
    By Preacher_22 in forum Ask a Question
    Replies: 1
    Last Post: 08-04-14, 03:34 AM
  3. CB website on Z10 browser
    By goodayeh in forum Site Feedback & Help
    Replies: 5
    Last Post: 08-04-14, 12:54 AM
  4. Problem in installing leaked v10.3.0.700 for stl100-1
    By jagdeepmarahar in forum Legacy Leaked/Beta OS
    Replies: 1
    Last Post: 08-04-14, 12:10 AM
  5. CB website on Z10 browser
    By goodayeh in forum BlackBerry Z10
    Replies: 4
    Last Post: 08-03-14, 08:56 PM
LINK TO POST COPIED TO CLIPBOARD