1. tlingit's Avatar
    I purchased an unlock code for my Curve 8900.
    I can get to the Personalization screen after I type MEPD, but nothing happens when I type MEP2.

    I have tried 2 different SIM cards, and same thing happens.

    On the Personalization screen it shows:
    SIM: Disabled
    Network: Disabled
    Network Subset: Disabled
    Service Provider: Disabled
    Corporate: Disabled

    If that makes some kind of difference.
    I've tried battery pulls just to start over...
    Any help would be greatly appreciated.
    06-09-11 09:42 PM
  2. CarrierUnlock's Avatar
    I purchased an unlock code for my Curve 8900.
    I can get to the Personalization screen after I type MEPD, but nothing happens when I type MEP2.

    I have tried 2 different SIM cards, and same thing happens.

    On the Personalization screen it shows:
    SIM: Disabled
    Network: Disabled
    Network Subset: Disabled
    Service Provider: Disabled
    Corporate: Disabled

    If that makes some kind of difference.
    I've tried battery pulls just to start over...
    Any help would be greatly appreciated.
    The device is already unlocked
    06-10-11 12:24 AM
  3. unlockcellpro's Avatar
    good to know
    06-10-11 07:26 AM
  4. freethisberrydotcom's Avatar
    Yep as Carrier Unlock explain it was unlocked prior to ordering the code.
    06-10-11 10:02 AM
  5. unlockthatphonecom's Avatar
    just put in your new sim card and it should pick up reception. If not take out battery and sim for 5 minutes and try again.
    06-10-11 02:39 PM
  6. blackberry-unlocking710's Avatar
    Network: Disabled - phone is unlocked!
    06-13-11 09:16 PM
  7. unlockcellpro's Avatar
    yes it is...
    06-16-11 01:55 PM
  8. CellUnlock.net's Avatar
    All Disabled/Inactive means the phone is unlocked. What you don't want to see is Active or Blocked.
    06-16-11 05:17 PM
  9. josh42's Avatar
    I think there is no serious issue in your BB.

    Your BB is already unlocked. The only thing is to do the steps carefully otherwise the problem will remain as it is....

    Put the sim back in your mobile n try again with after removing your battery for 10 mins........

    Thanks .......
    08-28-11 08:34 AM
LINK TO POST COPIED TO CLIPBOARD