07-29-16 09:41 AM
81 1234
  1. gtstang462002's Avatar
    To unlock the phone, the original Verizon Wireless SIM card must be in the phone.

    1. Go to Options -> Advanced Options -> SIM Card
    2. Flip your phone to horizontal mode and bring up the keyboard. To bring up the keyboard, hit the BlackBerry button and press Show Keyboard.
    3. Type "MEPD" without the quotes. This will bring up the SIM Card screen.
    4. You should see a list of Active and Disabled SIM locking categories.
    5. This time type "MEP2"
    6. You should get a dialog that says "Enter Network MEP code (10 left):"
    7. Enter the SIM unlock code you got from Verizon and hit the Enter button.
    ***MAKE SURE YOU TYPE IT EXACTLY AS YOU WERE GIVEN IT*** If you type it incorrect 10 times, you will render your phone useless. If it doesnt work after the first 2 times, call Verizon back and verify the number you got is right.

    Now that it is unlocked:
    1. Pull the battery out and pull the Verizon SIM card out. Easiest way is with a pencil eraser.
    2. Put the new SIM card from either TMobile of ATT in and put the battery back in.
    3. When the phone finally boots back up go to Options -> Mobile Network
    4. Change the Network Technology to GSM/UMTS
    5. Hit the back button and wait as your GSM carrier is detected and the phone is registered with them.
    This is the correct procedure and the only procedure that will work for this phone. They must be followed step by step or it will not work.
    03-16-09 02:04 PM
  2. ngreen's Avatar
    His question was how to know if his 10 tries were used up.

    PS you do not need the VZW sim card in any sim will do.
    03-16-09 02:08 PM
  3. quyen101's Avatar
    Yes i have the original sim. When i type mepd, the sim card info is displayed. Then i type mep2 and nothing happens.

    I've wiped using jl_comm and used .75 os.

    FYI. The Network status is blocked. Can it be my vendor.xml file in my BB Desktop manager.

    This is irritating but i appreciate all your help.
    03-16-09 02:27 PM
  4. quyen101's Avatar
    anyone have their network blocked?
    03-16-09 04:44 PM
  5. quyen101's Avatar
    I need 10 posts to pm
    03-16-09 04:45 PM
  6. ichan_cozt's Avatar
    hi there...

    i'm having the same problem here.. how to solve this? thx,,
    03-22-09 01:58 AM
  7. Carnag3's Avatar
    I have used both a AT&T and Tmobile simcard to unlock the Storm. IMO it works better than a Verizon/Vodafone simcard.
    03-25-09 01:22 PM
  8. kwith8n's Avatar
    did u figure it out? i have the same problems
    03-25-09 04:44 PM
  9. kwith8n's Avatar

    I cant pm yet nor do i have msn messenger... i will add ur pin and bb messenger you if thats ok
    03-25-09 04:59 PM
  10. ocgreenmachine's Avatar
    The only time I've done the unlock was on my 8830 as I was about to leave the country on a trip about 8 months ago... I didn't have an international sim card and was able to unlock while talking to a verizon rep on a land line.
    03-25-09 05:02 PM
  11. Ducter's Avatar
    Anyone figure out the network blocked deal? I purchased one off craigslist and never having Verizon before was not aware of the esn deal, I should have read up on things I see now. Anyways, I am a T-Mobile customer and have purchased a unlock code but I cant get the MEP2 screen to pop up and I think its cause the network is listed as blocked after typing MEPD.

    I called Verizon about 50 times in the past few days and have gotten enough information with each call to know the phone is not clean due to non payment.

    I have tried about a dozen times to get in touch with the seller, no email replies and doesnt answer the phone. I think he knows what the deal is. I know its partially my fault for not knowing what to look at before buying, but this has taught me a lesson... I now know how to buy from craigslsit/ebay.. you dont.

    Any help would be greatly appreciated.

    04-26-09 11:02 AM
  12. ngreen's Avatar
    You can email me or hit me on msn messenger and I can try to help you.
    04-26-09 11:27 AM
  13. smilepak's Avatar
    04-26-09 03:25 PM
  14. ngreen's Avatar
    Are you saying people who don't use VZW to unlock phone are breaking the law I don't think so.
    04-26-09 03:35 PM
  15. Ducter's Avatar
    Thanks for your help ealier ngreen..the seller finally said he would meet me this evening to take the phone back. We will see..


    For those that come across this problem it seems the seller tried unlocking it to many times and now its "hard locked" to Verizon.
    04-26-09 05:27 PM
  16. r6metzgar's Avatar
    having the same problem after i type mepd all that appears is
    network subset-unknown
    service provider-unknown

    11-07-09 06:02 PM
  17. CarrierUnlock's Avatar
    You have to have a sim card inserted.
    11-07-09 06:49 PM
  18. abercrombi3's Avatar
    anyone have their network blocked?
    just wondering if you managed to get it to work having the "network - block" status in the SIM category... im on my last limb here bought a UK Storm and can't for the life of me get the MEP2 to pop up contacted vodafone UK and they assured me the IMEI isn't blocked, tried wiping the phone and installing OS 5.0 to no avail
    12-07-09 07:23 AM
  19. CarrierUnlock's Avatar
    Sounds like you have exceeded the number os attempts allowed. You must take it to a local shop to cable unlock it.
    12-07-09 03:19 PM
  20. sophiekitty's Avatar
    i have the same problem when entering MEP2 and nothing pops up, i've been trying since last night ( Help Please
    01-28-10 06:44 PM
  21. CarrierUnlock's Avatar
    i have the same problem when entering MEP2 and nothing pops up, i've been trying since last night ( Help Please
    What device do you have? If it doesn't pop up more than likely it has already been entered. What does it say after entering "MEPD"?
    01-28-10 06:46 PM
  22. CellUnlock.net's Avatar
    i have the same problem when entering MEP2 and nothing pops up, i've been trying since last night ( Help Please
    Do you have a SIM card in the phone while going through the unlock?

    Also what you see besides Network after you type in the letters "mepd"?
    01-28-10 10:59 PM
  23. GD87's Avatar
    i happened to me too!
    make sure that the sim card its well inserted!
    it will have to ask you the pin code!
    after that you will see "invalid sim"!
    then you can enter your code!
    01-29-10 12:34 AM
  24. TheRemoteUnlockercom's Avatar
    I've worked out a few solutions for the 'UNKNOWN' problem, but the one that really surprised me recently was that the sim slot wasn't tight! The customer bought a t6 torx screwdriver and tightened it..worked perfect! Lol. I was baffled!
    01-29-10 09:11 AM
  25. ognjenm's Avatar
    I have same problem with my 9550

    I bought mep code, but i can't get window to enter it after I enter MEP2

    I only see
    SIM disabled
    Network Blocked
    Network subset Disabled etc

    Please Help
    01-29-10 05:38 PM
81 1234