1. stumil's Avatar
    I've seen similar posts before about this problem and I far as I can tell from the search, there's no solution. New and novel ideas much appreciated.
    12-03-10 08:05 PM
  2. Sarcasm Detector's Avatar
    Try setting a password and set your Left convenience key to lock.

    Test it out using both the lock button and the left con key.

    If it works, unset the password.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-10 08:13 PM
  3. stumil's Avatar
    Nope, Left Con key asks for password. I type in password, phone unlocks. When I lock with left shoulder button, phone won't accept any key entries. Did I do the sequence wrong?

    Appreciate the effort though!
    12-03-10 08:22 PM
  4. Sarcasm Detector's Avatar
    Hmmm... Will it let you password lock it while it's in keylock?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-10 08:40 PM
  5. stumil's Avatar
    Nope. When I lock with left shoulder button, left con key does nothing.
    12-03-10 08:42 PM
  6. Sarcasm Detector's Avatar
    Ok, I don't know why I asked you to pwd lock while in kbd lock. I must be either getting old or it's been a long day... Or both

    Have you tried a battery pull, or is that how you are "unlocking" it?

    What OS version are you running on the BB?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-10 08:58 PM
  7. stumil's Avatar
    I'm unlocking with battery pull, or simply calling the Bold from a landline.

    v5.0.0.979

    Thanks again for the effort. There'll be a little something extra in your holiday envelope this year!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-10 09:39 PM
  8. Sarcasm Detector's Avatar
    Ok, try this:

    Back-up your BB.

    Wipe then reload the same OS. Do not reload your back up.

    Test out your lock key with the fresh BB. If it works correctly, then reload your backup.

    If not then you will have to either downgrade or upgrade you OS to an older or newer version (repectfully).

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-10 09:48 PM
  9. stumil's Avatar
    Will do tomorrow and post results. Thx.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-03-10 10:02 PM
  10. stumil's Avatar
    Downgraded one iteration of OS. Now locking and unlocking just like it used to. Thanks Sarcasm. How long do I stay with the older OS?
    12-06-10 07:49 PM
  11. mitchsurp's Avatar
    Until the next official release. But you said you were using .979? Why not try the .1014 a few stickys up and see if the issue still exists.

    This seems remarkably similar to an iTouch issue my gf had with the home button. She thought it was a hardware issue. A quick software upgrade and it's like nothing was ever wrong.
    12-06-10 07:56 PM
  12. Kazziuz's Avatar
    This worked for me, i was about to wipe the device and do a clean install but i decided to try one last thing, clearing the event log. By holding the alt key and presing L+G+L+G, you bring up the event log and then you choose "clear log", that did the trick for me!
    03-19-11 03:53 PM
  13. Rootbrian's Avatar
    Never encountered that issue before. Maybe 5.0.0.979 is just not compatible with your blackberry. 5.0.0.1014 might be, give it a shot if you would like to. It's the latest 5-0 release.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-23-11 03:39 AM
  14. marwatk's Avatar
    My wife was having this issue, unlock not working and double key presses not registering.

    It turns out her camera button (right convenience key) was stuck in the half-pushed state. When pushed it would still trigger the conv key action going all the way in, but you could tell it was only getting one state (instead of click-click there was only click). I pulled on the camera button with the battery cover off and it fixed it.

    Hope that helps someone else.

    -Marcus
    04-01-11 04:16 PM
  15. AlexVDL's Avatar
    Marcus, THANK YOU so much for the information. I had the same problem, but I could not find an answer on the internet.

    I also have the problem that I can lock the keys with the lock button on top, but pressing it again won't work. I have the phone for 10 months and it always worked but the phone began acting weird recently. Also when typing I could never press two buttons at the same time which was very annoying.

    I opened the back cover as you said and tried to pull the camera button. It won't come out, but after a few times the lock button worked again and I could press two buttons at the same time again. Also seems that the phone is faster again!!! So it worked... it's the camera button that is stuck.

    Bad thing is that when I press the camera button, the problem is there again.

    So I probably have to send the phone back for repairs
    05-02-11 02:26 PM
  16. kcwilde's Avatar
    This very same problem happened to me, after 4 days of not being able to unlock the phone without taking the battery out and not being able press ALT with anyother buttons I took the phone apart myself and also found it was the camera button!

    I'm suprised to see there seems to be lots of people on the internet with exactly the same problem! RUBBISH CAMERA BUTTON!

    In heightened sight I could have just took the back off and wiggled the camera button around but to be fair I was in a blind panic! I'll never take the ALT button for granted again <3 <3 <3
    05-13-11 10:36 AM
  17. unlockcellpro's Avatar
    yup it's a manufacturing defect that puts you in trouble every time you need your phone the most.
    05-13-11 12:41 PM
  18. blackberryunlocker10sec's Avatar
    there's nothing worse that a phone that's not working!
    05-16-11 10:34 AM
  19. Deathcommand's Avatar
    Section that this is in.

    Hahahahahahaaa.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-16-11 10:38 AM
  20. unlockthatphonecom's Avatar
    one broken button tooooo much!!! I feel your pain, and fixing them is outragious. 20 minute fix cost me 55$ one time.
    05-20-11 08:09 PM
  21. michael105uk's Avatar
    Someone mentioned the camera button on the right side of the handset could be at fault/sticking.

    A bit of wiggling around then pressing unlock didn't work, but the camera and unlock button together did!!

    I'll update if this works again next time (happens 3 times a day currently).

    Michael
    05-23-11 12:33 PM
  22. blackberryunlocker10sec's Avatar
    sure do let us know.
    05-24-11 11:36 AM
LINK TO POST COPIED TO CLIPBOARD