1. bubsCB's Avatar
    I just unlocked a verizon blackberry tour to use for tmobile and it recieves texts but will not make a call ... it says sorry all circuits are busy at this time, etc. Please help ... I know its unlocked cause my friends AT&T sim card works ...
    02-01-10 05:25 PM
  2. m1keb3rry's Avatar
    Call T-Mobile and tell them your problem, they can't say anything for using a unlocked blackberry. I'm on T-Mobile with a att bold 9000 and I had to call them quite a few times to get my BB working rite. Sounds like they need to release the pin, its prob. Still connected with verizon, hope this helps good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-01-10 07:43 PM
  3. NorrisCell's Avatar
    Call T-Mobile and tell them your problem, they can't say anything for using a unlocked blackberry. I'm on T-Mobile with a att bold 9000 and I had to call them quite a few times to get my BB working rite. Sounds like they need to release the pin, its prob. Still connected with verizon, hope this helps good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    Please research his issue before offering advice. The No Circuit error on unlocked VZW devices has been discussed heavily and is not related to PIN issues.

    Using an unlocked GSM-only BB on another GSM carrier is much easier than using an unlocked CDMA/GSM BB.

    Your best bet would be to search the Tour forums. I know the NC error can be remedied on the original Storm by loading a specific software version on to the device, but the Storm 2 is not the same. Hopefully the software fix works on the Tour as well
    02-02-10 04:20 AM
  4. latinlegacy's Avatar
    install os 5.0 it will fix it
    02-09-10 05:33 AM
  5. pokerpro's Avatar
    This is the same problem I'm having too and have 5.0 installed and it still says the circuits are busy

    Posted from my CrackBerry at wapforums.crackberry.com
    02-28-10 10:23 PM
  6. rjnrobin1217's Avatar
    Had the same issue on my unlocked Storm a while back. I upgraded OS and didn't have the issue anymore.
    04-02-10 05:30 PM
  7. TheRemoteUnlockercom's Avatar
    Most people report that if they update their OS the problem will fix itself.
    04-03-10 11:03 AM
  8. CellUnlock.net's Avatar
    Upgrade/Downgrade and if it still doesn't work, have the SIM card replaced.
    04-04-10 11:26 AM
  9. TheRemoteUnlockercom's Avatar
    Any luck with upgrading the OS?
    04-05-10 09:06 AM
  10. CellUnlock.net's Avatar
    We had a customer over the weekend that upgraded to 5.0 and confirmed that it fixed the issue.
    04-05-10 09:49 AM
LINK TO POST COPIED TO CLIPBOARD