1. tmartz's Avatar
    Hey guys just need some help on my new tour. Okay so i bought it off a freind who had it unlocked and was running att with it. Okay so he said i need to change something to get it fully workig with tmobile service books>? So please help me out thanks guys
    10-25-09 02:31 PM
  2. udg21's Avatar
    Look in the storm thread how to get tmobile working and you have to load generic service books

    Posted from my CrackBerry at wapforums.crackberry.com
    10-25-09 03:24 PM
  3. CarrierUnlock's Avatar
    Have to agree with ugd. That should work for you.
    10-25-09 04:35 PM
  4. CarrierUnlock's Avatar
    10-25-09 04:36 PM
  5. porto35's Avatar
    good luck, you can't even make or receive call with your Tour when you use it with Tmobile. You will see the message: no circuit/channel availble.But you still can text, MMS and WAP following the above instruction.
    I stuck with 3 unlock Tour now even I have no problem when testing it with AT&T SIM card
    Last edited by porto35; 11-04-09 at 07:41 PM.
    11-04-09 01:07 AM
  6. BBStormTrooper's Avatar
    You are mistaken, I have a Tour from Sprint unlocked....for Tmobile and everything works perfectly fine..even the GPS. I just got it this week so I will figure out what settings you need to change to make it all work...but as far as mine goes, A BEAUTY!! (Traded my 8900 for Tour)
    11-06-09 09:18 AM
  7. CarrierUnlock's Avatar
    good luck, you can't even make or receive call with your Tour when you use it with Tmobile. You will see the message: no circuit/channel availble.But you still can text, MMS and WAP following the above instruction.
    I stuck with 3 unlock Tour now even I have no problem when testing it with AT&T SIM card
    Nope with a little skillset you can get it to work.

    You are mistaken, I have a Tour from Sprint unlocked....for Tmobile and everything works perfectly fine..even the GPS. I just got it this week so I will figure out what settings you need to change to make it all work...but as far as mine goes, A BEAUTY!! (Traded my 8900 for Tour)
    Exactly they work GREAT!
    11-06-09 06:05 PM
  8. mathemativ's Avatar
    You are mistaken, I have a Tour from Sprint unlocked....for Tmobile and everything works perfectly fine..even the GPS. I just got it this week so I will figure out what settings you need to change to make it all work...but as far as mine goes, A BEAUTY!! (Traded my 8900 for Tour)
    i have a unlocked sprint tour and trying to use it with tmobile....i got everything to work but its missing the browser and there is not icon for email setup.
    11-23-09 12:47 AM
  9. CarrierUnlock's Avatar
    Need to resend the service books if you haven't yet.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-23-09 12:50 AM
  10. mathemativ's Avatar
    Tried that...still no go..
    11-23-09 03:27 PM
  11. CarrierUnlock's Avatar
    Force load them as stated in previous threads, will need a backup of T-Mobile service books.
    11-23-09 05:09 PM
LINK TO POST COPIED TO CLIPBOARD