01-23-10 04:36 PM
32 12
tools
  1. snailrunner's Avatar
    My Pearl is going in for repair so I bought a 7290 on Ebay so I still have email access while the other BB is fixed. It was supposed to be unlocked, but when you turn it on is says Vodafone and it ignores my T-Mobile contract SIM. Any ideas?
    01-23-10 09:00 AM
  2. mostlydo's Avatar
    are you able to make or place calls while the tmobile sim is in?
    01-23-10 09:01 AM
  3. Motorcycle Mama's Avatar
    Options > Advanced Options > SIM Card > type MEPD and if it reads "Active" next to Network then it's still locked.
    01-23-10 09:26 AM
  4. whitebread_b's Avatar
    Go to Options -> Advanced Options -> SIM Card. It should say "Security Disabled"
    01-23-10 09:26 AM
  5. VDK's Avatar
    Go to Options -> Advanced Options -> SIM Card. It should say "Security Disabled"
    That's your SIM security, so it'll prompt you to enter your pin code.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-23-10 10:09 AM
  6. hootyhoo's Avatar
    Go to Options -> Advanced Options -> SIM Card. It should say "Security Disabled"
    No. As a previous poster explained. Options>advanced options>Sim card > then type MEPD. You won't see anything being typed but a new screen will appear. Network will say disabled if the phone is unlocked.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-23-10 10:54 AM
  7. CellUnlock.net's Avatar
    No. As a previous poster explained. Options>advanced options>Sim card > then type MEPD. You won't see anything being typed but a new screen will appear. Network will say disabled if the phone is unlocked.

    Posted from my CrackBerry at wapforums.crackberry.com
    And Active if locked.
    01-23-10 10:57 AM
  8. CarrierUnlock's Avatar
    More than likely it's not unlocked. There are a tons of devices that claim to be, but really arent especially on eBay.
    01-23-10 11:10 AM
  9. snailrunner's Avatar
    Thanks, did what hootyhoo suggested and this is what I see:

    SIM disabled (there isn't one in it)
    Network Inactive
    Network subset Disabled
    Service Provider Disabled
    Corporate Disabled

    So what now? If I put my T-Mobile SIM in it (and have tried both ways as it isn't at all clear which end goes in first!) it still says Insert SIM Card, with wireless on there is no signal and although it was only 15, I am wondering if I have wasted my money. The seller says she bought it from someone else on Ebay (that old chestnut...)
    01-23-10 12:27 PM
  10. CellUnlock.net's Avatar
    Thanks, did what hootyhoo suggested and this is what I see:

    SIM disabled (there isn't one in it)
    Network Inactive
    Network subset Disabled
    Service Provider Disabled
    Corporate Disabled

    So what now? If I put my T-Mobile SIM in it (and have tried both ways as it isn't at all clear which end goes in first!) it still says Insert SIM Card, with wireless on there is no signal and although it was only 15, I am wondering if I have wasted my money. The seller says she bought it from someone else on Ebay (that old chestnut...)
    Your phone is unlocked. Looks like the phone might not be reading the SIM card. Try taking out the battery and then put a piece of paper between SIM and back cover to make pressure on SIM. Metal contacts of the sim should face the inside of the phone.

    Then go to Options/Mobile Network and make sure the phone is on 2G only.
    01-23-10 12:30 PM
  11. snailrunner's Avatar
    With the SIM in, it seems to recognise it is there when the wireless is off - it says network: none, network selection mode: automatic. I turned the wireless on, then it says network: emergency service only, network selection mode: manual. When I select 'scan for available networks', it says scan failed, try later (although signal strength on T-Mobile in my house is excellent). Also, with wireless on the 'Insert SIM card' message is shown on the screen, this disappears when wireless is off.
    01-23-10 12:52 PM
  12. snailrunner's Avatar
    Also, although advertised as 7290, when I took the battery out I noticed it is actually 7730!
    01-23-10 12:53 PM
  13. CellUnlock.net's Avatar
    With the SIM in, it seems to recognise it is there when the wireless is off - it says network: none, network selection mode: automatic. I turned the wireless on, then it says network: emergency service only, network selection mode: manual. When I select 'scan for available networks', it says scan failed, try later (although signal strength on T-Mobile in my house is excellent). Also, with wireless on the 'Insert SIM card' message is shown on the screen, this disappears when wireless is off.
    Sounds like your Blackberry is locked, did you check by going to Options/Advanced Options/SIM card?
    01-23-10 12:55 PM
  14. snailrunner's Avatar
    Yes, I did - see the response at 1.27pm above. Before I type in MEPD, it says SIM card: no valid SIM card. This is the SIM from my 8110 which works perfectly (it's the blasted trackball that doesn't). Any more ideas, please?
    01-23-10 01:02 PM
  15. CellUnlock.net's Avatar
    Yes, I did - see the response at 1.27pm above. Before I type in MEPD, it says SIM card: no valid SIM card. This is the SIM from my 8110 which works perfectly (it's the blasted trackball that doesn't). Any more ideas, please?
    Sorry missed it by looking at that screen it indicates the phone is unlocked. Can you go to Options/Status and tell us what you see there?
    01-23-10 01:04 PM
  16. CellUnlock.net's Avatar
    The phone might also be not compatible with T-Mobile frequencies because if I recall the 7730 is Tri-Band
    01-23-10 01:06 PM
  17. snailrunner's Avatar
    Thanks for your patience and for taking the time to go through this with me.

    It says:
    signal -69 dBm (but keeps updating)
    battery 15% (left it charging for three hours so this isn't hopeful!)
    file free 2288752 bytes
    file total 13500416 bytes
    PIN/IMEI on next two lines as usual
    01-23-10 01:07 PM
  18. CellUnlock.net's Avatar
    Ok can you also go to Options/About and tell us what you see.

    Always a pleasure, that's what this community is for
    01-23-10 01:10 PM
  19. snailrunner's Avatar
    Well, I'm in London but I was in Kansas last summer and it worked perfectly well there!

    I won't type it all, but the first bit says:
    Blackberry 7730
    wireless handheld
    v4.0.0.171 (Platform 1.6.1.48)
    cryptographic kernel v3.8.0.24
    microedition configuration CLDC-1.1
    " profile MIDP-2.0
    " JTWI version 1.0
    " media version 1.1
    " PIM version 1.0

    Do you need any more? It's all copyright and patent stuff that seems standard.
    01-23-10 01:16 PM
  20. CellUnlock.net's Avatar
    Did you try updating the OS?
    01-23-10 01:19 PM
  21. snailrunner's Avatar
    No - I suspect I need something that I don't have in order to do that. I have the charger and the phone, that's all. Can't think of the technical word, but the thingy that plugs into the phone is not the same as my Pearl, so I don't have another cable I can use.
    01-23-10 01:24 PM
  22. CellUnlock.net's Avatar
    No - I suspect I need something that I don't have in order to do that. I have the charger and the phone, that's all. Can't think of the technical word, but the thingy that plugs into the phone is not the same as my Pearl, so I don't have another cable I can use.
    Yes you will need the Data cable in order to be able to upgrade the OS. That might fix the problem.
    01-23-10 01:26 PM
  23. snailrunner's Avatar
    But I don't have one, and if I get one I spend even more money - and I only wanted to use this for two weeks or so while my Pearl is repaired! It's due for an upgrade in March, and if it is not worth repairing (fingers crossed!) I will get a replacement phone free from T-Mobile. I have another phone I can use, but I'm due to move house and was keen to hang on to my email access while I find myself with no landline and no broadband. Maybe I have to admit defeat!
    01-23-10 01:29 PM
  24. CellUnlock.net's Avatar
    But I don't have one, and if I get one I spend even more money - and I only wanted to use this for two weeks or so while my Pearl is repaired! It's due for an upgrade in March, and if it is not worth repairing (fingers crossed!) I will get a replacement phone free from T-Mobile. I have another phone I can use, but I'm due to move house and was keen to hang on to my email access while I find myself with no landline and no broadband. Maybe I have to admit defeat!
    Let's try something else, Wiping the phone. Go to Options > Security > Click menu to wipe.
    01-23-10 01:35 PM
  25. snailrunner's Avatar
    Right, have done that - took my SIM out first, maybe it wouldn't have made any difference but I wasn't going to risk it! I now have three texts from BlackBerry to welcome me.
    01-23-10 01:45 PM
32 12
LINK TO POST COPIED TO CLIPBOARD