1. endee's Avatar
    Having problems unlocking Bell Canada Storm.
    I go to advanced options>sim card, enter mepd which brings up the SIM,Network, Network subset etc screen. Then when I enter mep2 nothing happens, the box to enter unlock code doesn't show.
    Network connection are off, I also tried with both a Rogers and original Bell SIM card. Also tried typing meppd and mepp2 with no change.
    Any help much appreciated
    08-19-09 10:14 AM
  2. Murphy8276's Avatar
    i am having this same exact issue..

    have asked around.. no one seems to know.. but i cant unlock my storm from verizon because of this.

    if u find out ever how to.. please pm me and post here.

    thanks

    -murph
    08-19-09 11:27 AM
  3. endee's Avatar
    Would this happen if the 10 tries at entering a code have been exceeded? Or does it matter if the Storm is activated or not?
    08-19-09 12:04 PM
  4. StayFly's Avatar
    I put the unlock code in my storm and I didn't get the conformation,I called verizon back and they said well if you can't put the code in now that means it unlock but when i put my friends tmobile sim in it didnt read it. And I suppose to do something different?
    08-19-09 12:26 PM
  5. breyton's Avatar
    sim card needs to be present when u enter the code !!!
    08-19-09 01:54 PM
  6. StayFly's Avatar
    yeah thats a given
    08-19-09 01:55 PM
  7. endee's Avatar
    Does it matter what SIM card it is?
    I tried it with both my Rogers SIM and the original Bell SIM
    08-19-09 02:21 PM
  8. endee's Avatar
    SOLVED IT!!!
    Problem was caused by loose/bad connection to the SIM card. I cleaned the SIM contacts and gently bent down the metal holder on the Storm and it worked!
    08-20-09 07:15 AM
  9. iMixProductionz's Avatar
    hey i have this same problem but so far nothing ive tried has worked ive been trying to figure this out for weeks and no solutions......yet... or so im hoping
    08-12-10 05:07 AM
  10. CarrierUnlock's Avatar
    Having problems unlocking Bell Canada Storm.
    I go to advanced options>sim card, enter mepd which brings up the SIM,Network, Network subset etc screen. Then when I enter mep2 nothing happens, the box to enter unlock code doesn't show.
    Network connection are off, I also tried with both a Rogers and original Bell SIM card. Also tried typing meppd and mepp2 with no change.
    Any help much appreciated
    Did you try MEP4 instead of MEP2?
    08-12-10 11:13 AM
  11. beccalouise17's Avatar
    ive done this , the box to put the code in didnt show , but i put my orange sim in & it read . except i cant send texts or make phone calls ?
    help.
    08-18-10 12:00 PM
  12. dave9211's Avatar
    Mine is exactly the same. Tried MEP2 and MEP4 nothing happens. It just says everything is disabled and cant make calls or send texts but my internet and bbm works!!
    10-12-10 12:58 PM
  13. lanzas1's Avatar
    Hey I don't have more entries there is other way to unlock?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-10 11:32 PM
LINK TO POST COPIED TO CLIPBOARD