1. ckhk212's Avatar
    Hi guys,
    I need some of your expert opinions. I recently purchased a Canada Rogers locked BB Z10, and I have the intention to unlock it. So I went on roamgalaxy and got the unlock code. Unfortunately, the code was entered successful, but I do not see the "Network unlocked" field, aka my phone did not get unlock properly.

    So I don't know does the latest firmware (10.2.*) caused this issue, but I would like some of your help? Please!

    Ideally, if some of you could recommend a 100% guarantee unlock site, please suggest it to me? or if there is something else I can do.

    btw, I have 6 tries remaining (I've tried unlocking with original sim, different carrier sim, and without sim). All resulted the same thing.

    Thank you guys!
    03-13-14 10:40 PM
  2. bungaboy's Avatar
    I think with Rogers you only enter the last 8 digits of the unlock code.

    Is that what you did? Or all 16?

    From my Z30 via CB10
    03-13-14 11:02 PM
  3. ckhk212's Avatar
    I think with Rogers you only enter the last 8 digits of the unlock code.

    Is that what you did? Or all 16?

    From my Z30 via CB10
    I only received an 8 digits code..
    03-13-14 11:24 PM
  4. diesel555's Avatar
    i ordered from roamgalaxy.com a few weeks ago as well and received a 8 digit unlock code for my rogers q10. I entered it and it said code unlocked successfully and it showed "Network Unlocked" afterwards; worked with a Telus sim after.

    I have a feeling some phones are just faulty (could be latest firmware as you suggested) and cannot be unlocked unfortunately. check out the other thread, seems like a pretty common problem.

    did you e-mail the website back? did they at least refund you?

    Hi guys,
    I need some of your expert opinions. I recently purchased a Canada Rogers locked BB Z10, and I have the intention to unlock it. So I went on roamgalaxy and got the unlock code. Unfortunately, the code was entered successful, but I do not see the "Network unlocked" field, aka my phone did not get unlock properly.

    So I don't know does the latest firmware (10.2.*) caused this issue, but I would like some of your help? Please!

    Ideally, if some of you could recommend a 100% guarantee unlock site, please suggest it to me? or if there is something else I can do.

    btw, I have 6 tries remaining (I've tried unlocking with original sim, different carrier sim, and without sim). All resulted the same thing.

    Thank you guys!
    ckhk212 likes this.
    03-14-14 01:36 AM
  5. ckhk212's Avatar
    i ordered from roamgalaxy.com a few weeks ago as well and received a 8 digit unlock code for my rogers q10. I entered it and it said code unlocked successfully and it showed "Network Unlocked" afterwards; worked with a Telus sim after.

    I have a feeling some phones are just faulty (could be latest firmware as you suggested) and cannot be unlocked unfortunately. check out the other thread, seems like a pretty common problem.

    did you e-mail the website back? did they at least refund you?
    Yes, in fact the customer support over there react quickly and they refunded me right away! So in terms of unlocking site, I like them very much. But unfortunately, my phone still remain locked.

    Last night, I decided to downgrade my phone from the latest official firmware to the leaked 10.2 firmware hoping I can unlock it then, but STILL DOESNT WORK! I hope some of you can help me out soon, otherwise I will need to sell the device!
    03-14-14 06:42 AM
  6. irweezyy's Avatar
    I would try a different sim anyways

    Posted via CB10
    03-14-14 11:59 AM
  7. irweezyy's Avatar
    Wow their (www.roamgalaxy.com) support is awesome!

    I just purchased unlock code, forgot to type in my IMEI and paid, sent them a message using the contact link, got a reply back within 5 min of the purchase!

    Posted via CB10
    kcorey likes this.
    03-14-14 12:12 PM
  8. ckhk212's Avatar
    I would try a different sim anyways

    Posted via CB10
    Yes, as stated from OP. I tried original SIM, different carrier SIM, and without SIM!
    03-14-14 12:37 PM
  9. irweezyy's Avatar
    Yes, as stated from OP. I tried original SIM, different carrier SIM, and without SIM!
    My bad, just scanned through the posts real quick. I just ordered an unlock for my z30, let's see if it works, I'm on the Rogers official os

    Posted via CB10
    03-14-14 01:29 PM
  10. irweezyy's Avatar
    Just got my unlock code, it was 8 digits and it worked perfect first try!

    Posted via CB10
    03-14-14 02:51 PM
  11. john.grisum's Avatar
    If the Rogers code does not work then it is a possibility that the code was incorrect in the Rogers Database. This is normally remedied by using the Blackberry Database rather than the carrier's database.

    -- freemyblackberry.com
    03-15-14 07:52 PM
  12. irweezyy's Avatar
    I find 9/10 times the issue is that the imei was typed incorrectly

    And weird thing was when I went to settings, about, and changed the drop down to hardware, my imei was not fully displayed. It only showed 15 digits, but when I went to the phone app and dialed *#06#, it showed my imei as 17 digits. When I sent away for the unlock code I sent the full 17 digit imei and the code worked perfect. I suspect that this is the reason for the issues.

    Posted via CB10
    03-17-14 12:07 AM

Similar Threads

  1. Closed: White Q10 Locked to Rogers
    By rebroker2009 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 7
    Last Post: 03-22-14, 12:48 AM
  2. Unlock Z10 - Koodo - Seamless
    By Donnamit in forum BlackBerry Z10
    Replies: 3
    Last Post: 03-15-14, 06:38 PM
  3. Gmail issue
    By RoccoI in forum BlackBerry Bold 9930/9900
    Replies: 4
    Last Post: 03-14-14, 09:01 AM
  4. BlackBerry Z10 won't turn back on at all
    By davemattf in forum BlackBerry Z10
    Replies: 12
    Last Post: 03-14-14, 12:35 AM
LINK TO POST COPIED TO CLIPBOARD