1. Dugganm's Avatar
    Hi,

    Two pronged question for you:

    Firstly, we have a number of Android devices enrolled in Android For Work via UEM 12.8, of which I am the administrator. I am more experienced in the admin of iOS devices in MDM software so trying to change polices on an AFW device is blowing my little mind! We push a facilities app onto each device via User Groups, but are experiencing problems with it and so I'd like to uninstall the app from a device but the UEM policies won't allow it. Can someone point me in the direction of what I need to enable/Disable to allow me to uninstall the app?

    Secondly, onto the problem we're experiencing...and I don;t believe this to be a UEM problem, but would like to rule it out.

    The devices we use are Samsung Xcover 4, all devices setup exactly the same by myself through UEM/AFW. The Facilities app we push onto the devices requires a username and password before it lets the user login. We are experiencing issues with random devices whereby the app won't login unless the device is connected to power, either at the wall or to a computer. As soon as you remove the device from power it stops allowing the user to login. This can happen at 89% battery or 21% battery on different devices, there is no rhyme or reason behind it because it also isn't happening on all devices.

    If we wipe a device and re-enroll it, the app works perfectly although we have had two come back with the same problem after around a week.

    Anyone any ideas? Thanks in advance
    07-08-19 06:02 AM
  2. Rodney Wilder's Avatar
    1) if memory serves, the way bb uem is configured for afw app forced install, it locks Uninstall. Only way I know of allowing Uninstall is to remove the force install and leave as optional. Will double check on bb uem 12.11 tonight though as I'm out of office all day.

    2) my experience with Samsung xcover4 has been poor as they have numerous bugs in software and basically never update it outside of once or maybe twice a year. Last os on north America sm-g390w for example was a November or October build from 2018.
    EU F version apparently has Android 9 now, so W version should receive similar this summer some time.
    That said, can attempt to clear app cache by going into system settings >apps, find app and clear cache. If that doesn't work, try clearing data as well.

    Have you reported the app oddness to developer? Could be something on their end they can resolve
    07-11-19 11:34 AM

Similar Threads

  1. BlackBerry Android Apps in Huawei new OS
    By Loc22 in forum BlackBerry Android OS
    Replies: 22
    Last Post: 09-11-19, 08:27 AM
  2. Question about Google's apps (Cobalt's method).
    By fla 15 in forum Android Apps (Amazon Store & APK Files)
    Replies: 18
    Last Post: 08-16-19, 07:10 AM
  3. Source CrackBerry 10 App after BlackBerry World Shutdown?
    By Shadowbolt in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 07-07-19, 04:30 PM
  4. Recommendations for Android Call Blocker App
    By skstrials in forum Ask a Question
    Replies: 0
    Last Post: 07-06-19, 07:12 AM
LINK TO POST COPIED TO CLIPBOARD