1. Adzeye's Avatar
    Hello everyone. I'm stuck on SOS mode on my Blackberry 9630 Tour and after hours of research, I'm giving up and asking for help here.

    The Blackberry in question was originally under Bell Mobility and was given out to professors at some university (who latter got iPhones, hence why I have this phone now). I'm trying to use it under Virgin Mobile.

    I have unlocked the phone. Typing MEPD under Advanced Options > Sim Card, I have
    SIM : Disabled
    Network : Inactive
    Network Subset : Disabled
    Service Provider : Disabled
    Corporate : Disabled

    I know my SIM card is not the issue. I have tried it on my friend's Android and it succeeds in making phone calls. Similarly, his working SIM card does not work on my Blackberry.

    My current "Mobile Network" settings are :
    Network Selection Mode : Automatic
    Network Technology : GSM/UMTS
    Network Mode : 2G

    Those are the only settings that allow me to connect to the Virgin Mobile network. Any other settings will cause an automated message from Bell "Please active your phone by contacting blabla" when I try to make any phone call. However, while I can see "VIRGIN" right to the "Mobile Network" field, I cannot see it in "Manage Connections" (the mobile network is turned on, but it is only written On with nothing next to it).

    I tried battery pull/wiping the phone multiple times. I have tried squeezing the sim card with a piece of paper.

    Can anyone help please? This is my first BB phone.
    07-22-12 05:47 PM
  2. SwitchBeach's Avatar
    You can't use that device on that network. It does not have the correct frequencies.
    07-22-12 05:55 PM
  3. Adzeye's Avatar
    Sorry, I forgot to specify that I want to be on Virgin Mobile Canada, which runs on Bell Mobility's networks.

    On another note, why does my device connect to Bell Mobility when the settings is Global or 1XEV?
    Last edited by Adzeye; 07-22-12 at 06:06 PM.
    07-22-12 06:01 PM
  4. SwitchBeach's Avatar
    Yes, however, Virgin Mobile Canada (and I knew that's what network you were trying to use) is HSPA only. It's not CDMA and it doesn't have a GSM component.

    You would need to get an account on to Bell's CDMA network.
    07-22-12 06:08 PM
  5. Adzeye's Avatar
    Alright, thank you very much !
    07-22-12 06:20 PM
  6. blackberry-unlocking710's Avatar
    The device isn't supporting the frequency bands needed for that carrier..
    But, you can still use your unlocked Blackberry with GSM carriers such as Rogers.
    Last edited by blackberry-unlocking710; 09-04-12 at 07:45 AM.
    09-04-12 07:43 AM
LINK TO POST COPIED TO CLIPBOARD