1. sdg0512's Avatar
    I got my Tour a few days ago. I wanted to set different SMS ringtones for different contacts, so I went to my contacts and I set one up for my sister. She texted me after and the ringtone worked fine but every text after that played her specified SMS ringtone and not the standard one I set for SMS. I set another one for my boyfriend contact and then had him send me a text. Again, it worked fine but every text after that (THAT DID NOT HAVE A SPECIFIED SMS TONE) played his SMS tone and not the one I set for standard SMS alerts.

    Help Please Somebody!!
    08-05-09 12:12 PM
  2. wickedmotorhead's Avatar
    I am having a similar issue, but not the same. I downloaded a bunch of ringtones from here and set them as standard tones for the ringer, SMS, and email alerts. Worked fine for a few days and now today it doesn't play any of them and they say they are invalid when I try to manually play them now. Any help here would be appreciated. Thanks.

    Shane
    08-06-09 06:21 PM
  3. GregMargie's Avatar
    I got my Tour a few days ago. I wanted to set different SMS ringtones for different contacts, so I went to my contacts and I set one up for my sister. She texted me after and the ringtone worked fine but every text after that played her specified SMS ringtone and not the standard one I set for SMS. I set another one for my boyfriend contact and then had him send me a text. Again, it worked fine but every text after that (THAT DID NOT HAVE A SPECIFIED SMS TONE) played his SMS tone and not the one I set for standard SMS alerts.

    Help Please Somebody!!
    I have an 8330, so not sure if it is the same on the Tour, but I don't believe you can set a different sms tone for different contacts. You can set a different ring tone for individuals.

    On my 8330 I can set a particular sms tone, but that is what will play for every sms that comes in.
    08-06-09 06:28 PM
  4. chopmen's Avatar
    i have the same problem and have posted on here but cant get a response from anyone but i do think it is only on the sprint tours. i bought the ringo app and it works but gives me false text message tones 10 to 15 times daily so either way so far there both not working properly but if you figure it out i would love to know how to fix it
    08-06-09 09:41 PM
  5. stoner51's Avatar
    While in the contacts, BB button, edit, set ringtones and alerts has two options phone and messages.
    It works fo me
    steve
    08-06-09 09:45 PM
  6. adelcastillo78's Avatar
    I selected my own ringtone and sms tone in my normal profile. but then I have a few people with different ringtones. when i set those contacts with a different ringtones, their SMS tone that sounds is the phone's default SMS tone. I just went to those specific contants and added the SMS tone I use for everyone in that contact's SMS custom alert.

    Hope this helps...
    08-06-09 09:49 PM
  7. chopmen's Avatar
    yes that would work unless you wanted certain contact to have there own distinct tone for sms. and for stoner you are on verizon and im pretty sure sprint is the only one with this problem
    08-07-09 08:07 PM
  8. Principal Skinner's Avatar
    I have the exact opposite happening to me ...I set specific alerts for sms texts from my children and use another alert tone for all other sms texts. This works fine for a few hours each day and then out of the blue, the specific alert I have set for my children's texts plays for all of my text alerts. Go figure. If I do a battery pull or use quick pull, it works again for a while and then goes back to misbehaving ...any ideas ?
    08-12-09 03:47 AM
  9. BamaMan44's Avatar
    I got my Tour a few days ago. I wanted to set different SMS ringtones for different contacts, so I went to my contacts and I set one up for my sister. She texted me after and the ringtone worked fine but every text after that played her specified SMS ringtone and not the standard one I set for SMS. I set another one for my boyfriend contact and then had him send me a text. Again, it worked fine but every text after that (THAT DID NOT HAVE A SPECIFIED SMS TONE) played his SMS tone and not the one I set for standard SMS alerts.

    Help Please Somebody!!
    I have the same problem on my verizon tour. It annoys me and I haven't been able to fix it. I have reset the tones and reassigned but no luck so far.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-12-09 04:11 AM
  10. tourofduty's Avatar
    maybe it's an OS bug? my changes take effect only after a battery pull, BUT sometimes, i'll hear the previous ringtone, but it switches back
    08-12-09 05:25 PM
  11. saintj's Avatar
    I actually have this set and have had it this way since day 3. No issues. I wonder what you all have in common with your tours (i.e, apps, mods,)
    08-12-09 05:30 PM
  12. kboyd7's Avatar
    I am having the same problem, I have a BB Bold 9700 assign SMS text alerts for different contacts and only get default alert... It is driving me crazy!!
    01-15-10 01:42 AM
  13. briton.hefty's Avatar
    Erm, as I remember the current version of the 4.0 OS out has a bug with assigned alerts. Search the rest of the forum there is some more official verbage out there.
    01-15-10 02:20 AM
  14. JMac24's Avatar
    I have different rings, sms, mms, and bbm for each person. Works flawlessly.
    01-15-10 02:48 AM
  15. Kimo91's Avatar
    i have one set for normal texts and for my contacts i have specific ringtones and sms ringtones for them. my tour works flawlessly
    01-15-10 08:09 AM
  16. MissLinda's Avatar
    I'm having the same issue on my Sprint Tour.

    I have custom SMS text sounds for a few people and I want them to keep their custom sounds.

    However, it seems whenever I get a text now, I'm getting the last custom person who has texted me's SMS tone instead of the one set in the default.

    Its getting frustrating! Has anyone figured out how to fix this?
    01-17-10 06:29 PM
  17. SweetBerrys's Avatar
    I have the Sprint Tour and am experiencing the same problem.
    01-19-10 05:11 PM
  18. lgdlman's Avatar
    I have had the same issues with my 9630 (VZ). Problem is when you add or synch new contacts, VZ 9630 automatically assigns a default ring tone and message tone for each new contact. I've even gone into numerous VZ stores and it's the same. I've also been on Tech Support (Vz & BB) and they confirmed the same thing.

    Once you add a new contact, you have to go back in - "Edit" and then change the ringtone. Problem is that while editing in the Contacts, you can't set different tones for Phone Ring, SMS or Email for each contact. I had much more flexibility on my old Curve.
    01-19-10 08:09 PM
  19. jfran's Avatar
    actually posted on 1/19 about it too.

    http://forums.crackberry.com/f141/ma...s-help-404686/
    01-25-10 02:33 PM
LINK TO POST COPIED TO CLIPBOARD