Built for Business - Learn more about BlackBerry KEY2
  1. Synergie's Avatar
    My GPS works no problem... I can click on Find Location and 'Where I AM' and the little bubble shows the right location, but my actual Map is messed up! Like nothing shows... it either stays white, or loads a location that looks like central America or something. And if I try to pan away from that area or zoom out to see where the map is showing, it just goes white and doesn't reload the map to show properly at all. Sometimes it just shows white with my location showing in the middle of a white screen, or sometimes will show the diagonal lines, and will say 'zoom level too high' even if I zoom all the way out!

    Anyone know what's going on? Or how I can fix it?
    Last edited by Synergie; 09-06-09 at 10:58 PM.
    09-06-09 10:42 PM
  2. eripmu's Avatar
    I'm on wap right now so I'm not able to see what your service provider is. But from my understanding it won't work on Verizon unless you have VZNav. I may be wrong but I'm pretty sure thats the case.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-06-09 11:09 PM
  3. Synergie's Avatar
    I am on Telus and we have free use of Maps... unlike Verizon. And besides, the GPS is working fine in other apps AND in BB Maps... it finds my location and successfulyy tells me I am at 'XX extension' for example, which is correct... it's just the map itself that is not working.

    I have also double checked the settings in Options... it's set correctly for location and maps is 'North America' so I am at a loss.

    Now to compound the problem...
    Just in case the app is messed up, I just downloaded the newest (official) OS from my provider. It's .77 vice the .40 that came installed. I installed the new OS on my desktop and now the BB won't even connect to Desktop Manager... this keeps getting more and more fun... not!
    Last edited by Synergie; 09-06-09 at 11:29 PM.
    09-06-09 11:24 PM
  4. Synergie's Avatar
    Ok I fixed it... I uninstalled another app I had loaded called Poynt, which I noticed put an option in the BB Maps menu.... I deleted that just to be sure it didn't corrupt maps. Then I uninstalled and re-installed BB Maps via the App Loader. That worked....

    So I guess maybe Poynt corrupted BB Maps??
    09-06-09 11:58 PM
LINK TO POST COPIED TO CLIPBOARD