1. jmprater11's Avatar
    If this has already been asked, I apologize but I cannot find it.

    Whenever I look at or even delete all of my email and SMS messages in my Tour, there is still an envelope icon on the screen that says I have a message.

    Voice mail is empty, SMS is empty and emails are all deleted.

    Thanks in advance.
    11-02-09 11:13 AM
  2. SPORE's Avatar
    Probably a missed call.
    11-02-09 11:19 AM
  3. passtheboll's Avatar
    Check in your saved messages: in both messages and sms and mms, press the BB key and scroll down to View Saved Messages and select it, you might have some unread messages there. That is more often than not the problem.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-09 11:32 AM
  4. gamy2121's Avatar
    If this has already been asked, I apologize but I cannot find it.

    Whenever I look at or even delete all of my email and SMS messages in my Tour, there is still an envelope icon on the screen that says I have a message.

    Voice mail is empty, SMS is empty and emails are all deleted.

    Thanks in advance.
    Make sure you seperate ur sms/mms from email and also what I do is just use my message folder to read all emails instead of going into each seperate email account...that way you can see when u havent read an email or if you have missed calls... which would be cause for the icon
    11-02-09 11:38 AM
  5. jmprater11's Avatar
    Probably a missed call.

    Just went through and deleted all call logs and the envelope is still there.
    11-02-09 11:42 AM
  6. zrome's Avatar
    battery pull
    11-02-09 11:43 AM
  7. jmprater11's Avatar
    Checked all saved messages and there are none.

    Battery pull did not work.

    The new message indicator (red asterisk) stays on even after I have read the new messages.

    Small problems, but still annoying.
    11-02-09 12:01 PM
  8. Muley05's Avatar
    Email yourself a new message. When that one gets deleted, it should take care of it.

    Annoying, and something that should not be necessary, but I had to do the same thing to get rid of the missed call icon at the top.
    11-02-09 12:09 PM
  9. jmprater11's Avatar
    Tried everything here to no avail.....

    Even upgraded to .61 and it is still there....

    Has been since day 1.

    Just received a new SMS and the alert changed to the envelope with the asterisk and 2 (like there were 2 new SMS) when I went and read the SMS and deleted it, the icon changed like there was 1 new SMS, but when you look into the messages, there is nothing in there.
    11-02-09 12:22 PM
  10. passtheboll's Avatar
    Also try going to all your inboxes and on the top date, press the BB button and select Mark Prior Read. I had to do that with my new Tour because for some reason I had 30 new SMS.
    11-02-09 04:41 PM
  11. Kydd's Avatar
    i have the same issue on my tour along with the red LED flash when there is nothing.
    i tried the mark all prior open / no luck
    but the batterie pull worked for me
    11-02-09 06:18 PM
  12. yurtletheturtle's Avatar
    I had the same problem when I upgraded to 5.0 and only with 5.0. Battery pulls didnt help and all folders,voicemail, and missed calls were erased. When I downgraded back to .40, it went away and never came back.
    11-02-09 10:23 PM
  13. jmprater11's Avatar
    I found the "missing" message.

    There was a new SMS message stored in my SMS Inbox folder and I stumbled on it.

    Thanks for all the replies. Phone is working great now. The LED no longer flashes once I check the current SMS.
    11-05-09 10:09 AM
LINK TO POST COPIED TO CLIPBOARD