1. Karol11222's Avatar
    hey guys i just bough a verizon blackberry tour unlocked. thats my first blackbery i am on att network and my problems are i only can call and text, no email no browser, also when i call the screen shows my number and its different number.... iam going to change my plan to blackberry plan today but i just want to make sure when i change it everything will work... what should i do?
    11-13-09 09:59 AM
  2. bduschel's Avatar
    Thats the danger with using an unlocked phone. You never know how the network will react to using the unlocked phone?
    11-13-09 10:03 AM
  3. Karol11222's Avatar
    so there is nothing i can do about it?
    11-13-09 10:05 AM
  4. Iceman0803's Avatar
    I'm guessing (based on my experience with VZW) that your issue is because you haven't set up a data plan for your tour yet. Ideally, once you add the data plan and your device is provisioned the web browser should show up and you'll also have email functionality. However it may not be that easy as you're trying to use the device with att. You'll likely have to do some manual setup steps to get things working properly.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Iceman0803; 11-13-09 at 10:13 AM.
    11-13-09 10:11 AM
  5. Karol11222's Avatar
    ok ill try to change my plan to blackberry does any one know how to change my number in the dialing screen?
    11-13-09 10:23 AM
  6. gritmaster's Avatar
    ok ill try to change my plan to blackberry does any one know how to change my number in the dialing screen?
    Not sure whether this would be the same for your device/carrier but you could try the following. Options>Advanced Options>Sim Card. I am able to set my phone number from there

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-09 10:31 AM
  7. dbone15's Avatar
    This should apply to the Tour as well

    http://forums.crackberry.com/f135/ho...rm-95xx-107154
    11-13-09 10:42 AM
  8. Karol11222's Avatar
    Not sure whether this would be the same for your device/carrier but you could try the following. Options>Advanced Options>Sim Card. I am able to set my phone number from there

    Posted from my CrackBerry at wapforums.crackberry.com
    i did change that but still the old number is showing up on the calling screen under my number
    11-13-09 10:49 AM
  9. gritmaster's Avatar
    Read the link that dbone mentioned . Towards the end of the first post it talks about the actions required for changing the number.

    Part of text copied here

    If you are using an unlocked Verizon Storm and have "Activation Required" on your home screen or your phone number displays incorrectly, Dial # # 000000 (Send). In the Menu, change the mobile directory number to your phone number and select save. The device will reboot and activate/display the correct number
    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by gritmaster; 11-13-09 at 10:56 AM.
    11-13-09 10:53 AM
LINK TO POST COPIED TO CLIPBOARD