1. Sprockethead's Avatar
    I am having a problem that I could really use some help with at work. Please, please, please.

    BACKGROUND INFO---------------

    * I use a 930, of course.
    * I am on Sprint.
    * I recently downgraded from 5.0 to .77. So everything about the OS is the way it is "supposed" to be.
    * I use BIS. While my company offers BES, I do not want to pay the extra $20 to Sprint to get it.
    * When I sync, I do so wireless bluetooth style between blackberry and Desktop Manager. Never had a problem.

    PROBLEM!--------------

    A couple days ago, I upgraded the Desktop Manager to the latest, whatever that is. I didn't do a sync for a couple days.
    Today I open up the new version and this happens:
    1. DM says "initializing."
    2. The phone links up with DM like it should.
    3. DM flashes the PIN number and asks if this is correct. I say YES/OK.

    Suddenly, my Blackberry handset asks me for a password in order to continue. I enter a new password twice because I am a dumbass and a little confused at this point. The screen reads "PROPERTY OF <my company>." Suddenly, it looks like I'm on the BES, but nothing is syncing. My plan doesn't support it!!

    WTF happened?! How do I get my old BB back?

    Any advice is greatly appreciated.
    12-02-09 08:37 AM
  2. Sprockethead's Avatar
    Oh, and I just went to Security, and it looks like I have a ******* IT policy! This is one reason I did not want to be on BES! Aren't these IT policies impossible to get rid of? I will not be able to sell phone ever, etc...
    12-02-09 08:40 AM
  3. FF22's Avatar
    While I'm not really familiar with the BES stuff I know I have seen threads on "how to completely remove IT policy" so you might be able to find a solution if you look around.

    Others may have better info.

    Good luck
    12-02-09 09:15 AM
  4. eBoyDog's Avatar
    To be on BES you need a an account and activation set on the BES "server", then to be activated you would have needed to complete the enterprise activation on the device. It's strange that you suddenly have an IT policy on your device, to remove it there are a few websites that offer a procedure but I myself in working with my Tour, tried that and it didn't work. To truely remove it properly, I wold suggest JL Commender, wipe it and then reload the device OS; that would assure that's gone but of course, you need to back up your device prior to doing such!!!

    You can activate a BB device to BES by using the DM, I'm a BES admin and I have done that often using a device that had no service and connecting it directly to the BES to activate it which afterwards all BES functions work as long as it's connected to the DM on a workstation. The new BES 5.0 allows a web based DM that allows the user to "fix" their own device and re-activate if necessary.

    I would advise you contact your email/BES admin and see if they can offer some insight, I suspect it may have something to to do with a partial activation as the first thing that comes down to the device is the IT policy and yes it's possible to start activation though your desktop manager.

    IT Policies are not necessary bad, it just depends how tight your email admin is with it, personally the policies that I put out for my users are very liberal and allow them full control over their devices since it's my attitude that they are the ones responsible for their device, not me but once in awhile I mess with one or two of my BB users and turn off their cameras...
    12-02-09 11:24 AM
  5. Sprockethead's Avatar
    Thank you for the detailed reply. Here is the whole story in gruesome detail.

    A few weeks ago, I asked my company to put me on the BES server. They gave me a password. I entered it, but no BES server. I called Sprint. They told me that since I don't pay for BES, I get no BES.

    I thought: case closed. I just never followed up. Apparently I never synced with my Desktop since. Or else, more likely, the upgraded DM included the "activate BES" feature that you described.

    I wiped the device with JL_Cmder. No luck! Password, etc is requested even when plugging the bricked handheld back into my computer and choosing the Loader.exe file from the AppLoader folder.

    Based on what you say, it sounds as if the IT policy/password is being loaded immediately before any of the software is - almost like the password is housed in DM and not the handheld.

    Would it help if I uninstalled Download Manager and THEN used JL_Cmder and THEN used the Loader.exe file to load the software and THEN reinstalled Download Manager?

    Thanks, by the way, for all your help.
    12-02-09 11:36 AM
  6. prettifem4u's Avatar
    I would honestly uninstall and redo it all.
    12-02-09 02:14 PM
  7. Sprockethead's Avatar
    That's what I'm trying to do. I've used JL_Cmder 3 times so far, and am currently wiping it a 4th time. I guess I can't "restore" any information from a backup without causing the BES lock to re-implement itself.
    12-02-09 02:31 PM
  8. FF22's Avatar
    Desktop Manager does allow selective restores. Go to backup/restore and pick ADVANCED. Then select what you want - it may still not work in your case but ....

    good luck
    12-02-09 03:15 PM
  9. Sprockethead's Avatar
    Which line item only restores 3rd party apps? Do you know?
    12-02-09 03:17 PM
  10. candurin's Avatar
    Are you using option #5 on JL Commander? #4 will wipe it clean but only #5 will remove the IT policy and completely set it back to factory. I know this because I had to remove the IT policy on my phone in order to transfer all my contacts prior to re-activating my corporate BES (and IT policy).
    12-02-09 03:23 PM
  11. ds28's Avatar
    Which line item only restores 3rd party apps? Do you know?
    Unfortunately, apps are not backed up with a typical backup operation. The utilities (bbsak, etc) can do it for you, as can the work-around using DM/switch device. However, they are not part of the backed up databases. You can redownload via the source, or whatever app store (mobihand, etc) you purchased via. Sorry if this is bad news, I learned the hard way too awhile back.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-02-09 06:24 PM
LINK TO POST COPIED TO CLIPBOARD