1. mach10's Avatar
    After all this time waiting for a new Google Maps to be released, it still does not work on my Telus Tour .... from what I'm seeing I'm not the only one with this issue, Bell(whom uses Telus's network) seams fine.... WTF!!! I've red before that Telus blocks the ports for Google Maps to use their own GPS app, however if it's true or not I cant say... this sucks I wish this would work considering the fact that Telus actually advertises with the damn app also!!! god damn it ...
    10-22-09 03:21 AM
  2. thymaster's Avatar
    Install the official Sprint or Bell OS release 4.7.1.57 and Google Maps will work now. Just remove the vendor file that's all.
    10-22-09 03:46 AM
  3. freaksite's Avatar
    its never worked on my storm and im with bell, didn't matter which OS or which version of google maps.
    10-22-09 03:52 AM
  4. mach10's Avatar
    Install the official Sprint or Bell OS release 4.7.1.57 and Google Maps will work now. Just remove the vendor file that's all.
    Trying this now, will report back if it works or not.


    Thanks for the advice
    10-22-09 04:02 AM
  5. WarHog's Avatar
    Telus does not block the ports, gps works fine on telus, I have a 8330 and gps is fine! I haven't tried google maps 3.2 but my 3.1 works fine!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-22-09 04:06 AM
  6. MusicMtl's Avatar
    I am running .57 on Telus and gmaps gps is not working for me. It works in all other apps, though.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-22-09 07:24 AM
  7. kccman's Avatar
    Google Maps 3.2 or 3.02 works fine with 4.7.1.57. I'm running 5.0.0.230 and neither work. I'm with Bell.
    10-22-09 08:55 AM
  8. Sammy_T's Avatar
    Hello all,

    Like most of you I can't get my Google Maps to work on my Telus Tour. I am currently running v4.7.1.40 on the tour. I read that I could download the new os from Bell and use it on my phone. I downloaded the file to my laptop, ran it, removed the vendor.xml file, plugged in my phone to DM (version 5.0) and it did not dectect the new os system it just took me to a page that allows me to add/remove applications from my phone. I also tried running it from the apploader.exe file but it still didn't install.

    Am I doing something wrong?

    Thanks for any/all help !

    PS - The odd thing is that my poynt finds my exact GPS location (based on the green light) but my Google Maps GPS is still triangulating
    Last edited by Sammy_T; 11-11-09 at 03:09 PM.
    11-11-09 02:43 PM
  9. arkaroola's Avatar
    I ended up installing a 5.x hybrid OS and Google Maps works fine now.
    11-11-09 03:05 PM
  10. Sammy_T's Avatar
    Where did you get it from? And did you do what I did in terms of process or have I missed a step?

    Thanks
    11-11-09 03:18 PM
LINK TO POST COPIED TO CLIPBOARD