1. LinxuSx's Avatar
    Hey all

    For some reason the facebook application is almost unbearably slow. I've tried clearing the cache, doing a full reset yet to no avail. I have full service and the internet is extremely fast when tethered but on the fb app it takes like 2-3 mins to load pictures and about 15 seconds to refresh updates. Any reasons for this?

    Btw I'm on vzw.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-12-10 02:52 AM
  2. _aaron's Avatar
    the fb app is just bad/slow.
    01-12-10 03:41 AM
  3. Ducaticorse's Avatar
    Agreed, sure seems slow for a dedicated app. I've since put a bookmark to the mobile site and if I'm doing more than a quick check/look I jump straight into my browser and onto the m.facebook.com site instead.
    01-12-10 05:44 AM
  4. Pathtek4's Avatar
    ^yep, was just going to mention that! That FB APP is horribly laggy
    01-12-10 06:29 AM
  5. wryun's Avatar
    Same here!
    I agree, for a dedicated app, fb for BB is terrible. I use m.facebook.com as well. )c:
    01-12-10 10:31 AM
  6. sasha#WN's Avatar
    Yeah that app sucks!
    01-13-10 03:28 PM
  7. spierce7's Avatar
    Have you tried an android phone? Their facebook app is snappy. Like... It takes under 2 seconds to refresh everything. It's like the internet is faster on it, but the BB is just slower at processing everything due to processor and OS.
    01-13-10 03:50 PM
  8. tdrus1's Avatar
    nah, the FB BB app just blows.
    01-13-10 03:53 PM
  9. cultureshot's Avatar
    Yeah, I don't think it has anything to do with the device. I have a brand new Bold 9700 and the Facebook app runs very slowly on it. I wish RIM would devote some programmers to sorting that app out. Seems like a pretty basic thing to screw up!
    01-13-10 03:59 PM
  10. Success100's Avatar
    +7 on how bad the app SUCKS on BB's
    01-13-10 06:03 PM
  11. uhupong's Avatar
    As I coming from touch pro2 WM phone. I say the FB app are equally bad on both device.

    The functional FB app that I've personally tried and think it useable is on iphone/itouch.

    Both devices are on sprint network.
    01-13-10 06:16 PM
  12. SmIL3Z_C's Avatar
    FB app is brutal I just use it to go straight to the mobile site which I like way better anyways
    01-13-10 06:16 PM
  13. xooxlisaxoox's Avatar
    FB is always so slow. They need to improve it somehow!!
    01-13-10 06:51 PM
  14. juicebox666's Avatar
    FB app is sooooooo bad. I've turned the email notifications off and use SocialScope for most of my Facebook needs.

    For those of you that use the mobile version, try x.facebook.com. It's much prettier then m.facebook.com and still runs well.
    01-13-10 06:54 PM
  15. ragnarokx's Avatar
    not completely the app's fault - under 4.7 it ran so slow i just deleted it. under 5.0 (now .419/4.21 hybrid) it runs at a very usable speed.
    01-13-10 06:58 PM
  16. kyky489's Avatar
    For those of you that use the mobile version, try x.facebook.com. It's much prettier then m.facebook.com and still runs well.

    Ya this version is pretty cool i use it on my itouch all the time. I cant get that version to work on my bb though? The login page comes up but when i type in my info then click log in, nothing happens?
    01-14-10 01:52 AM
  17. jakethesnake011's Avatar
    I have noticed that the FB app is very bad. I dont like it at all. I tam trying to get used to the mobile site but that is kind of bare. I am waiting for my social scope invite to come...might be a lost cause.
    01-14-10 02:05 AM
  18. l3lueberry's Avatar
    it used to be good i dont know what happened to it, i get notifications like hours after it happened
    01-14-10 02:43 AM
  19. Thenewbdm's Avatar
    I have a VZW Tour 4.7 and my FB is awful iam a little scared to run the hybrid
    01-14-10 02:57 AM
  20. chefnilla's Avatar
    FB app is only ok in my opinion. Though, I have noticed periods of really slow response time to be the fault of FB itself, not the app. Sometimes the app on my BB is faster than the high-speed internet in my house and I feel like it is the site's own fault, especially when my friends are complaining how slow their internet connection is while on FB.
    01-14-10 04:07 AM
  21. Vagrant_1's Avatar
    I know its not super fast but it runs ok for me besides the whole FB site lags IMO but on topic I normally get all my notifications right after they been posted so I can't complain

    Posted from my CrackBerry at wapforums.crackberry.com
    01-14-10 04:54 AM
  22. al3azim's Avatar
    the FB 1.7 IS Terrible. The prior versions we much better. at least 1.5 or 1.6 but 1.7 for sure blows. It takes a long time to populate all teh pictures and once that is done, it seems to flow ok.
    01-14-10 09:18 AM
  23. juicebox666's Avatar
    it used to be good i dont know what happened to it, i get notifications like hours after it happened
    Wouldn't that be an email problem? I believe the Facebook app uses email for monitoring notifications.
    01-14-10 09:49 AM
  24. juicebox666's Avatar
    I have a VZW Tour 4.7 and my FB is awful iam a little scared to run the hybrid
    Don't be afraid!

    I just put the .419 leak on my Tour a few weeks ago and I've never been happier. It runs so much faster, reboots faster and updates several features.

    Cruise the forums for installation guides and where to find the files. It's quite easy!
    01-14-10 09:50 AM
  25. juicebox666's Avatar
    I know its not super fast but it runs ok for me besides the whole FB site lags IMO but on topic I normally get all my notifications right after they been posted so I can't complain

    Posted from my CrackBerry at wapforums.crackberry.com
    I agree. The Facebook site is often slow, which makes me think the servers are congested or they're doing maintenance? Even on a fast connection, loading pics or flipping through profiles can be a chore!
    01-14-10 09:52 AM
LINK TO POST COPIED TO CLIPBOARD