1. emsetsfire's Avatar
    I have the BB Tour 9630 and I switched about a few days ago from a Motorola Razr2 and now my caller ID doesn't seem to work properly. Whenever I receive a call, it shows up as 'Unknown' even though I have the feature in my monthly plan. It also only seems to happen when I receive calls from a cell phone. I've been through hundreds of threads and I've tried several different things but nothing seems to work for me. Thanks in advance for the help.
    11-27-09 09:53 PM
  2. lastraid's Avatar
    1. make sure the contact is in your address book.
    2. make sure that you have the area codes used in the contact number.

    See if this helps
    11-27-09 10:04 PM
  3. emsetsfire's Avatar
    Yes to both. Still having the same problem.

    Edit: Even if the number wasn't in my contact book it would show up on caller ID, no?
    11-27-09 10:06 PM
  4. lastraid's Avatar
    Yes to both. Still having the same problem.

    Edit: Even if the number wasn't in my contact book it would show up on caller ID, no?
    No, I know VZW does not transmit this info. You might see unknown, or city and phone number, but the name does not show unless it is in the address book. Landlines actually program in and transmit the info.

    If your plan is correct and everything on the phone is correct, I would have your carrier create a trouble ticket to find out why it is not working properly.
    11-27-09 10:12 PM
  5. emsetsfire's Avatar
    Well I'm from Canada so I'm actually not with Verizon. I just tested it out with my home phone and it shows the number. It just doesn't work with cell phones. It's really strange. I figured it had to do with the phone's settings but I've tried changing the area code but no luck.
    11-27-09 10:18 PM
LINK TO POST COPIED TO CLIPBOARD