1. MCRunning's Avatar
    So I just upgraded to the official version of 5.0, rebooted, now I am getting a 507 error message saying there is no OS installed.

    Is there anyway way to reload it on Mac or am I SOL and have to do it on a Windows using the apploader?

    Edit: I just got some message asking me to install an OS on my phone, I select 5.0 and got this message

    BlackBerry Desktop Manager failed to update your BlackBerry device. The device was disconnected.
    Last edited by MCRunning; 03-30-10 at 03:16 PM.
    03-30-10 03:13 PM
  2. ekim2010's Avatar
    I would suggest doing a clean wipe using JLCmder and then reload OS using apploader on Windows.
    03-30-10 03:26 PM
  3. teshny's Avatar
    MCRunning, people have been able to recover from this using the MAC. I ran into the same issue last night but after wasting 2 hrs i gave up on my mac (i even tried XP in VMWare) .. thankfully i have a windows box as well.

    I just used app loader and everything was perfect in 20 mins.

    I felt like it was Microsoft slapping me in the face for buying a MAC!
    03-30-10 03:54 PM
  4. phila's Avatar
    I have the 'Reload Software 507' message halfway through upgrading the OS, now its stuck and will not reboot.

    DM said the update failed and was waiting for the phone to restart but its stuck on the 'Reload Software 507' message.

    I'm completely stuck. I use a Mac and have no Windows alternative.
    03-30-10 04:33 PM
  5. rsklein105's Avatar
    i had the same problem. Reload Software 507 error. so i went to the mac section of the forums. one person said that they just plugged it back in for a few minutes and it will start up again. it worked for me. so plug your phone back into your mac and just give it a few minutes, maybe 5 it was less than 10. good luck!!
    03-30-10 04:40 PM
  6. golfgal's Avatar
    I had the 507 error as well this morning when trying to download 5.0 from the DM on my Mac. I just let the Tour sit for a bit, still connected to the DM on the Mac, and the problem finally took care of itself. No further problems, although all the apps I'd downloaded (including ones I'd paid for) had disappeared, even though I had backed them up with the DM before I updated the OS. I've had to spend some time today getting them all back, since I didn't know any other way to do it other than downloading them again.
    03-30-10 04:43 PM
  7. SevereDeceit's Avatar
    although all the apps I'd downloaded (including ones I'd paid for) had disappeared, even though I had backed them up with the DM before I updated the OS. I've had to spend some time today getting them all back, since I didn't know any other way to do it other than downloading them again.
    Many people who used a Mac to install this OS are having the same issues. You are not alone...
    03-30-10 04:46 PM
  8. Ginny Hastelow's Avatar
    I sort of have the same problem can someone help me please. my bb phone just shines LED light then it shows 507 error for 5 seconds an repeats . reboots, i tried to do the app loader but when it gets onto the last bit it just disconnects
    07-09-10 09:09 PM
  9. graspDESIGN's Avatar
    Yes, loading an OS using a MAC has been presenting a ton of issues showing the 507 error.

    Just a heads up though...it takes a while for the OS to load to the phone. Some people have been disconnecting their BB's thinking its stuck, when really its just taking forever to load. This happens on both Windows and MACs, so try to be patient.

    Also, if patients fails you and you disconnected during the process, reconnecting MIGHT solve the issue if you are lucky and the load continues. If not, you basically have a BB with no OS on it. So in this case, you may be able to try a fresh load on both platforms (PC or MAC), but it may not take.

    If it does not take, on a PC you are able to "force" the OS to load on your BB. Not sure if this works the same on a MAC though, but it could be worth a shot... Maybe Ill try it on my old Storm using my MAC and see if in fact it does work later.
    Last edited by graspDESIGN; 07-09-10 at 09:34 PM.
    07-09-10 09:32 PM
LINK TO POST COPIED TO CLIPBOARD