1. tigi.ericmoon's Avatar
    I thought I was being tricky in trying to deny cross-application permission to one of my apps, but something has gone wrong.
    Now I get an error message when I re-boot, letting me know that CaptureIt has been halted because it is denied cross application access. Okay, maybe I accidentally denied cross-application access for the whole device by accident. Whoops.
    The problem now is that I csant get into options - I get a java exception error box and that's that.

    HELP!
    09-29-09 02:30 PM
  2. Syco54645's Avatar
    battery pull???
    09-29-09 02:42 PM
  3. mallinj's Avatar
    Load up Device Manager on your 'puter and remove the offending application. Then battery pull and reboot.
    09-29-09 02:46 PM
  4. Accidental Post's Avatar
    Boot into safe mode....yes there is a safe mode

    Battery pull when replacing the battery hold down the escape key during boot

    Voila safe mode should be able to get into options and reset the permissions.
    09-29-09 03:10 PM
  5. tigi.ericmoon's Avatar
    A battery pull was the first thing I tried.
    Initally it was GoogleSync that was being terminated. I removed that, and now it's CaptureIt that is running into the cross-application roadblock.
    I think I may have denied cross-application access globally, and if I follow the path of removing the offending application, I would be removing everything!

    This would be easier if I could get into options. The error reads: Uncaught Exception java.lang.Error

    I'm guessing I will have to wait til I grt home to fix this while connected to my computer.

    Reinstall the os?
    09-29-09 03:12 PM
  6. Accidental Post's Avatar
    Did you even read my post?
    09-29-09 03:13 PM
  7. tigi.ericmoon's Avatar
    Escape key?
    09-29-09 03:18 PM
  8. Accidental Post's Avatar
    The back arrow to the right of the trackball

    This works on all Os's higher than 4.6

    via Knowledge Base):

    Remove the BlackBerry battery and reinsert it
    Hold down the Escape key after the red LED goes out and keep holding it (The escape key is the one that looks like a sideways “U” shaped arrow by the trackball on the Bold commonly called the “back key/arrow”)
    You will then see this dialog box to the right and click ok
    To exit safe mode just remove the battery and reinsert again
    09-29-09 03:19 PM
  9. tigi.ericmoon's Avatar
    Ok, I tried a couple times to trigger Safe Mode without success.
    My Tour boots up normally, displays the error dialog and my thumb hurts.

    Other suggestion?

    Thanks for trying to help me!
    09-29-09 04:44 PM
  10. Accidental Post's Avatar
    are you holding that key all the way through the boot process?

    Hold it down then put the battery back in
    09-29-09 04:56 PM
  11. GG1's Avatar
    my thumb hurts.

    Other suggestion?

    Thanks for trying to help me!
    Use your other finger?

    Posted from my CrackBerry at wapforums.crackberry.com
    09-29-09 07:24 PM
  12. tigi.ericmoon's Avatar
    Deleted CaptureIt and it booted up normally without any error dialogues.
    Got into options, reset permissions and rebooted. Reinstalled CaptureIt and now everything is fine.

    Just for ****s and giggles, I tried again to get it into "safe mode", but I just can't make it happen; Whether I hold the escape key down after the red light goes out or hold it as I'm putting the battery in, it just wouldn't happen.
    09-30-09 07:33 AM
  13. GG1's Avatar
    Glad it worked out..... At the same time i learned about safe mode will reading this thread.
    Thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    09-30-09 07:41 AM
LINK TO POST COPIED TO CLIPBOARD