1. Nabooy's Avatar
    This is getting really frustrating as I had the very same problem with my previous Bold 9700. I keep getting an error whenever I try to play a video on YouTube.

    "An error has occurred attempting to play media."

    Could it be a problem from my carrier or something? Please help me out 'cause I never had YouTube to work just fine on my previous phones, not even once.
    10-25-10 07:24 PM
  2. Reuben80's Avatar
    I think it should work with wifi or with BIS if you have APN settings configured

    Posted from my CrackBerry at wapforums.crackberry.com
    10-25-10 11:35 PM
  3. Altarocks's Avatar
    I've had that problem at times as long as I've had my Torch. I haven't figured out the cause. It always occurs after what looks to be buffering, then the video completely closes after the message.

    It's annoying, and it does occur when using WiFi (I don't watch videos over 3g). At least it doesn't happen frequently.
    10-26-10 04:16 AM
  4. Nabooy's Avatar
    It seems that you would have the same problem even while on WiFi. Please can anyone get me a solution for this? I watch a lot of videos on YouTube so it's a huge problem to me.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-26-10 04:40 PM
  5. Nabooy's Avatar
    Anyone please help!
    10-27-10 10:52 PM
  6. Nabooy's Avatar
    Anyone help please???
    10-29-10 09:44 PM
  7. andrewjames's Avatar
    Are you BES? YouTube worked awesome on my torch until I signed my phone up on our company BES server.
    10-29-10 11:19 PM
  8. Nabooy's Avatar
    No and I don't even know what a BES is actually.

    Edit: Ok guys, it seems to work fine while on Wifi even though it's a bit of slow but anyone can tell me how to work it normally?
    10-30-10 11:24 AM
  9. MOTH477's Avatar
    Is there a solution to this?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-01-10 11:51 PM
  10. iN10Se's Avatar
    Same issues with my 9700/9800 on Fido here in Canada. All I did was change the APN in Options - Device - Advanced System Settings - TCP IP. Checked APN settings enabled, and in the APN slot I typed in my carrier APN (internet.fido.ca). You'll have to find APN settings for Vodafone, but that worked for me.
    11-01-10 11:59 PM
  11. Nabooy's Avatar
    Same issues with my 9700/9800 on Fido here in Canada. All I did was change the APN in Options - Device - Advanced System Settings - TCP IP. Checked APN settings enabled, and in the APN slot I typed in my carrier APN (internet.fido.ca). You'll have to find APN settings for Vodafone, but that worked for me.
    Is it working for you while turning the WiFi off? Because mine seems to work fine now when I have my WiFi on. That's kinda weird.
    11-02-10 11:22 AM
  12. MOTH477's Avatar
    Same issues with my 9700/9800 on Fido here in Canada. All I did was change the APN in Options - Device - Advanced System Settings - TCP IP. Checked APN settings enabled, and in the APN slot I typed in my carrier APN (internet.fido.ca). You'll have to find APN settings for Vodafone, but that worked for me.
    My APN settings are enabled and APN is set to wap.cingular. Still videos start playing and stop with error message popping up.
    11-02-10 11:25 AM
  13. realcanuk's Avatar
    I used to get an error when playing youtube videos partway through the video. Since I entered the wap info I havent had it for awhle. I think you need to put the user and password as well. You can find that for your carrier with a google search.
    11-02-10 01:24 PM
  14. Nabooy's Avatar
    What user and password? I have no clue what you're talking about so please fill me up with more details. I don't know where or how to find the APN settings for my carrier as I'm not living in the US or UK. My carrier is Zain (formerly known as Vodafone, in Bahrain).
    11-02-10 06:48 PM
  15. realcanuk's Avatar
    That I wouldn't know. If you can't find it with a google search I would call the carrier. I assume its a similar system to rogers which has an apn user name and password for the system, same for all users

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-10 10:14 PM
  16. genomalice's Avatar
    Same issues with my 9700/9800 on Fido here in Canada. All I did was change the APN in Options - Device - Advanced System Settings - TCP IP. Checked APN settings enabled, and in the APN slot I typed in my carrier APN (internet.fido.ca). You'll have to find APN settings for Vodafone, but that worked for me.
    Thanks dude, I can confirm that worked. I'm also on fido with the rogers 9800:-)

    Btw, fido's phone lineup is laaaaacking!

    Posted from my CrackBerry at wapforums.crackberry.com
    11-03-10 11:02 AM
  17. russia4ever's Avatar
    When I got an unlocked Blackberry Torch from Rogers and put it on Fido, my YouTube was telling me ""An error has occurred attempting to play media."

    I was frustrated for the first 2 month, but I got it fixed it...


    How I fixed it...Stupid Fido, when they add BlackBerry Data plan, they only give permission for blackberry data, cuz they have a few phones data plans.

    When I talked to Fido Representative (called Fido 611), She said that the Data plan on her Fido Computer had few check marks that blocked access to the internet on regular phones and iPhone. As soon as she lifted them, i restarted my phone and youtube began to play.


    They don't like Fido customers getting unlocked phones, so they (I assume) purposely block such things.

    Hopefully this helps
    03-11-11 03:13 PM
LINK TO POST COPIED TO CLIPBOARD