1. luqman24's Avatar
    Ok guys, The BB Torch started arriving at the Rogers locations where im living in today adn my friend picked it up as he was eligible for an upgrade. I must admit i was really impressed with it and now thinking of picking up one even though im not with Rogers instead with Fido which mean I have to pay the full retail price. Anyways, ive been playing with it and though I should check out how YouTube videos play on the Torch and that when I found out they look low quality compared to my current Bold 9000. Yes ive tried optimizing it and looking for the HQ button with no luck. So for those of you who currently own the Torch, is this how YouTube videos look or did forget to do something in order to play them in HQ. If this is true this may be a deal breaker to me since I watch alot of YouTube videos when im away from home which is most of the time. If your thinking im a picky person, yes i am and Ive tried to change that but couldnt so i cant help it now. Please tell me this isnt what YouTube videos look like on the Torch or I will be dissapointed otherwise. Thanks for your help guys!
    10-10-10 10:00 PM
  2. Shao128's Avatar
    If you are streaming over 3G the quality is significantly lower than if you stream on wifi. My suspicion is that youtube is doing this and it is not device controlled.
    10-10-10 10:48 PM
  3. papped's Avatar
    If you select HQ version (for the videos that have it) they look pretty good. Some videos don't have HQ so they look worse

    Posted from my CrackBerry at wapforums.crackberry.com
    10-10-10 10:55 PM
  4. VRaptor's Avatar
    On BB you get a 3gp version of the clip which is lower quality. Not sure why it does this but it does.
    10-10-10 11:04 PM
  5. Roo Zilla's Avatar
    try m.youtube.com. That might yield better results, but then again, it might not.
    10-10-10 11:19 PM
  6. luqman24's Avatar
    Yeah I was streaming it on 3G and on m.youtube.com. I was also looking for the HQ button on the videos I've watched in HQ before but couldn't. So I may have to do a little more hands-on and see if this isn't a real problem and i'm hoping its not.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 01:01 AM
  7. Rikter's Avatar
    Youtube has sucked on every blackberry to date due to how it is streamed, as mentioned above.

    One day, i hope, some third party app maker will actually make an app that would stream perfectly. I bet that app would make a lot of $$ for the maker.
    10-11-10 02:08 AM
  8. lazerus's Avatar
    Youtube on Blackberry is perfect, clear quality.

    LoL

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 07:14 AM
  9. luqman24's Avatar
    Youtube has sucked on every blackberry to date due to how it is streamed, as mentioned above.

    One day, i hope, some third party app maker will actually make an app that would stream perfectly. I bet that app would make a lot of $$ for the maker.
    The quality on my bold 9000 is decent and plays in HQ but yesterday when I tested it on my friends new Torch, the quality was low or bad to be specific enough. But I hope this isn't the case and I have missed something.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 10:28 AM
  10. MobileMadness002's Avatar
    Youtube for me is very clear. Does not buffer either.
    10-11-10 11:02 AM
  11. N2Shift's Avatar
    I have the same quality on my Torch as I had on the Tour. Most videos are pretty good and work in "HQ". Some videos don't have an "HQ" option and look bad.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 11:34 AM
  12. Rickroller's Avatar
    Not sure what the fuss is..I stream Youtube vids fine. Comparing the vids side by side with my wifes iP4 the only difference is her better screen resolution..but she even commented the differences were hardly noticeable. Only time I get poor quality vids is when they're a poor quality upload to begin with.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 12:01 PM
  13. luqman24's Avatar
    Not sure what the fuss is..I stream Youtube vids fine. Comparing the vids side by side with my wifes iP4 the only difference is her better screen resolution..but she even commented the differences were hardly noticeable. Only time I get poor quality vids is when they're a poor quality upload to begin with.

    Posted from my CrackBerry at wapforums.crackberry.com
    Hmm that must be why then. Haven't tested more videos out when I had the chance but definitely will do more testing before I can judge on the vid quality cuz looks like this isn't a common issue from what most of you have said.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 01:07 PM
  14. Shao128's Avatar
    So here's a little more on my theory of YouTube being the culprit serving different streams based on being on carrier network vs Wifi.

    The video I'm using in this test is available in 720p on the desktop.
    YouTube - Call of Duty: Black Ops - Multiplayer Teaser

    Connecting on 3G serves up a video that looks like this (1:1 scale):


    The video it is sending is a low quality 3GP video over RTSP. Heres the direct link: rtsp://v1.cache2.c.youtube.com/CjYLENy73wIaLQmei8GiM-z3hxMYJCAkFEIJbXYtZ29vZ2xlSARSBXdhdGNoYJbc8Y2TnI_M TAw=/0/0/0/video.3gp

    Connecting on Wifi serves this:


    Direct link: http://v8.lscache3.googlevideo.com/v...=youtube_gdata
    Which is a HQ mp4 file. If I click that link even when connected to carrier network (3G) it plays fine for me.
    10-11-10 01:26 PM
  15. luqman24's Avatar
    I played the mp4 HQ quality on my Bold 9000 and it was awesome but there were a couple of times where the video was buffering but not sure if its my phones processor that can't handle it or the connection speed but on wifi it was fine. Looks like i'm gonna have to do another test drive.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 01:39 PM
  16. papped's Avatar
    Buffering means network connection, not processor.
    10-11-10 01:42 PM
  17. North-Face's Avatar
    Youtube for me is very clear. Does not buffer either.
    Very clear for me too, wifi & 3g.
    10-11-10 01:44 PM
  18. N2Shift's Avatar
    Weird. I just tested this out and it works the same for me. Don't know if it's YouTube or the Carrier pulling tricks through BIS.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-10 02:26 PM
  19. papped's Avatar
    Pretty sure it's some kind of failure on mobile youtube site, since the higher quality version exists but isn't even offered and it only happens with some videos... (the youtube mobile site is notorious for being crap).

    The source of the connection shouldn't even matter. They should offer a HQ or LQ version if it exists regardless of connection type.
    10-11-10 02:37 PM
  20. AJ_Franklin's Avatar
    Except for the buffering, which happens with all phones, my YouTube experience has been satisfactory with my new Torch. I don't use YT that frequently that it is a problem and the buffering mainly occurs on HD feeds on YT mobile.

    If I used YT a lot I would compare several different devices with the same d/l from YT before making a decision.
    10-11-10 03:45 PM
  21. StormJH1's Avatar
    I have a 9700 on OS5.0, and the quality is embarrassingly bad compared to an iPhone 3G. Very happy to be a Blackberry owner overall, but anytime something involves YouTube or Web Browsing, I'm embarrassed to hand my phone to an iPhone user to show them. The combination of the 1/2 size screen and terrible resolution/buffering is almost unwatchable.

    There is an app called Player for YouTube on OS5.0, but it doesn't solve the quality problem. I only have it because it makes it a little easier to search/navigate, and you can also upload your photos with it.
    10-11-10 04:11 PM
  22. thymaster's Avatar
    The video on my torch is looking clear and fine. No complaints here.
    10-11-10 08:56 PM
LINK TO POST COPIED TO CLIPBOARD