1. theophany#CB's Avatar
    Hi all,

    I'm new here, but not that new to Blackberry. I had a Bold 9700 for a while last year and have just returned to BB from iPhone 4 for the Torch (which I love).

    However, the device seems intent on making me hate it. I'm getting very regular (every 10-20 seconds) lock-ups whereby the black clock icon shows and renders the device unresponsive for 15 or so seconds.

    I've tried reflashing the OS to vanilla (tried .225 and now back to .337) all with no luck. I've been pulling the battery like a trooper to make sure that the device memory is clear and no luck. I have been regularly checking CPU usage whilst my most commonly used apps are in use to be sure that there isn't something sapping it dry and nothing sticks out as being particularly needy. These apps tend to be Facebook, Twitter, BBM, SMS, Email, Browser, MySpace and Social Feeds, though these are rarely all open at the same time and I am very vigilant with cleaning apps out of memory when they're not in use.

    When I first got the device a few days back I didn't have this problem at all, it worked perfectly with no hanging or lock-ups. However, BB Maps was not installed on the device (no idea why, lbs_ribbon would not enable it and it definitely wasn't hidden on the device anywhere) so I headed to BB's site and downloaded the latest OS6 for my carrier (Vodafone UK). Commence headaches. Although the install went like a breeze and restoring my data also went without a hitch, this is when the lock-ups started.

    It has now gotten so bad that when I whip it out of my pocket to check the time I can't even get the screen to illuminate for a few seconds, let alone unlock the device. The weird thing is that the OS interface hasn't become sluggish as such, it still works as snappy as ever but it is paused up by this black clock icon rotating as if my Torch is having some kind of epic brainstorm on the meaning of its existence. Very annoying!

    Any advice would be greatly appreciated. I'm now running the de-vendor.xml'd Beeline release of as the .2xx release Vodafone UK last authorised was a dog to the point where I had to reflash without a battery...
    11-22-10 05:12 AM
  2. jeffreii's Avatar
    You should list your apps in case someone here has had a problem with one or more of them.

    Your best bet, I think, is to start from scratch. Reinstall the OS. Only restore data like calendar/contacts/tasks/memos/messages etc. Don't install any apps and see how it runs for awhile. If everything is good, start installing one or two apps a day...when it starts locking up, if it does again, you'll know what's causing it.

    On the other hard, if it locks up with no apps installed and nothing but data restored (no settings), you'll know that something has gone wrong with your hardware.
    11-22-10 06:43 AM
  3. homer1475's Avatar
    locking up like that is very uncommon, I have yet to see the clock icon at any time, ok maybe a couple times I've seen it but it was while installing an app.
    List what apps you have installed, more then likely one of these are the culprit.
    11-22-10 07:21 AM
  4. theophany#CB's Avatar
    Social Feeds
    BB Maps
    Word Mole
    Brick Break
    BB Application Centre
    App World
    BB S/MIME Support
    AOL IM
    DOD Root Certs
    Documents To Go
    Wireless Music Sync

    Plus the standard components of v6.0.0.337 such as Setup, Email Setup, etc etc.

    It's worth noting that I am vigilant with memory management and when I'm done with an app I will close it, though I don't know if there are any remnants of the processes left in memory...?
    11-22-10 07:27 AM
  5. homer1475's Avatar
    Yeah I'm not seeing any apps that could cause what your seeing, I have most of them installed myself.

    But as jeffreii posted I would start with a reload of the OS, and give it a day then slowly start adding in your apps one at a time and give them a day or so. What your seeing is surly not the norm for the device.
    If it continues and our within your 30 days, by all means take it back something is defective hardware wise.

    On a side note. Frequent battery pulls aren't required with the torch(most times soft resets do the trick). To my knowledge(and my own device) there is no memory leak in OS6, least not the OS6 for the torch.
    11-22-10 07:31 AM
  6. theophany#CB's Avatar
    That's what I figured, the apps are pretty innocuous. I don't see how it could be a hardware fault personally though as until I reinstalled the OS to get maps on the device it was working flawlessly and without any of these pauses. Bizarre, huh?
    11-22-10 07:36 AM
  7. homer1475's Avatar
    Definitely bizarre. Now that you have just said you reinstalled the OS to get bbmaps working, makes me believe it's just a matter of a small bug in the OS when you reloaded it. I would reload it again and I'll almost guarantee you that all this will stop.
    11-22-10 07:46 AM
  8. theophany#CB's Avatar
    Just reloaded the OS with the bare minimum and the problem has only gotten worse. It's now stalling at every key press. It's stalling when I open the tray - that's how sensitive to a stall it is.

    This is freaking ridiculous! :/
    11-22-10 08:11 AM
  9. homer1475's Avatar
    Take it back, if you can. Has to be a hardware failure somewhere.
    11-22-10 08:13 AM
  10. theophany#CB's Avatar
    Just phoned my carrier and they're having a brand-spankin' new Torch delivered to me tomorrow morning. Praise be, hopefully all we be solved tomorrow morning!
    11-22-10 08:39 AM
  11. jeffreii's Avatar
    Just reloaded the OS with the bare minimum and the problem has only gotten worse. It's now stalling at every key press. It's stalling when I open the tray - that's how sensitive to a stall it is.

    This is freaking ridiculous! :/
    When you reloaded the OS, did you restore anything?

    Also, have you done a few battery pulls since loading the OS? It's always a good idea.

    If you didn't restore anything and you've done the battery pulls, the only thing left to try is to remove your MicroSD card.

    After that, if it doesn't improve, take it back and get a new one.
    11-22-10 08:40 AM
  12. theophany#CB's Avatar
    I don't have a MicroSD card and have been doing plenty of battery pulls. I did try running the OS as a blank slate each time (didn't bother using backup and restore through AppLoader - did it through BBDM later on) and whilst the lockups were less intense without my data, they were still bad enough to make my experience with the device terrible.

    Even then, I've only been using the device since Friday and haven't got much data on it at all, so I would like to think that my data wouldn't be causing it so many issues, but who knows...
    11-22-10 10:45 AM
  13. jeffreii's Avatar
    If your device was locking up with a blank slate OS install there's definitely a hardware problem. I'm confident your replacement will be much better!
    11-22-10 11:47 AM