1. outkazt17's Avatar
    Hey everyone, I bought an unlocked torch to use with Telus. I got my SIM card activated, put it in, but all I get is SOS on the signal strength bar. I verified with Telus that the SIM works. When I go into mobile settings, the only network that my phone picks up is rogers wireless. I called Telus again, and they suggested that the phone was not properly unlocked, but when I check, it is saying disabled, so it seems that the phone is unlocked. Any ideas?
    10-14-10 09:50 AM
  2. Username5300's Avatar
    I'd say it is still tied to rogers in some way.
    10-14-10 09:53 AM
  3. damann's Avatar
    is 3g turned on? telus only runs on 3g
    10-14-10 10:06 AM
  4. outkazt17's Avatar
    Yes, It is set to 3g only. When I do a manual network scan, it only comes up with rogers. I just took my sim card out and tried it in a friends Telus HTC phone and I got signal and was able to make a call. Does BIS stuff have to be set up before I can get signal? because that hasn't been done yet. I will still have my old PIN attached to my Telus account.
    10-14-10 10:35 AM
  5. Zolutar's Avatar
    I think you might be still locked and need the mep4 code (SP or service provider lock). I thought only Bell and telus had the double lock? is rogers doing it now with the torch?
    Last edited by Zolutar; 10-14-10 at 11:57 AM.
    10-14-10 11:54 AM
  6. outkazt17's Avatar
    Upon investigating this further, I found that I did in fact have it set on 2G & 3G. Thats why its picking up rogers as the carrier. When I switch it to 3G only, it picks up nothing.
    10-14-10 12:56 PM
  7. freethisberrydotcom's Avatar
    When you go into OPTIONS>ADVANCED>SIM CARD> TYPE MEPD ...

    DO YOU SEE THIS ?? If all securities are disabled, then your phone is unlocked ..

    10-14-10 01:47 PM
  8. MusicMtl's Avatar
    This might sound silly but are you sure you are inserting the SIM card properly? I once put it in backwards by mistake and had the exact same issue.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-14-10 08:04 PM
  9. outkazt17's Avatar
    The SIM card is inserted correctly. Update, I swaped the phone out with another one and when I am in a 3G area, it works like a dream. when I am out of a 3G area, it goes SOS. Its not the SIM card, or the phone by the looks of it, but perhaps a problem with the software that won't allow it to switch networks when not in a 3G area? I dunno. I am new to this.
    10-14-10 09:34 PM
  10. mladeniki's Avatar
    When you click options, type sim, then sim card will show up as an option, tap it and check if at the top it says "security disabled"

    By the way im using an at&t torch with bell and all works fine
    10-14-10 10:06 PM
  11. outkazt17's Avatar
    My last phone (Storm 2 9550) was always in 1XEV here at home, but the new torch doesn't seem to have the 1X setting, it only gives 3 options: 2G, 3G, and 2G and 3G. Is there a way to make it connect to a 1XEV network?
    10-14-10 10:11 PM
  12. mladeniki's Avatar
    1XEV is CDMA, the torch is a GSM phone so it will run 2G / 3G, Bell & Telus only have a 3G network since it is quite new, so it will only pick up their 3G signal and not their older networks 1XEV signal which some of their devices still connect to
    10-14-10 10:18 PM
  13. kccman's Avatar
    Give me a call at the shop Jer. 5192*5-2588. I'll be here for a bit

    Posted from my CrackBerry at wapforums.crackberry.com
    10-14-10 10:18 PM
  14. outkazt17's Avatar
    I pm'd you KCC. And to answer your question mladeniki, yes, it says Security disabled on the sim card screen
    10-14-10 10:36 PM
LINK TO POST COPIED TO CLIPBOARD