1. f_d's Avatar
    I just got an unlocked AT&T-branded 9800 running 6.0.0.246, I'm subscribed to Fido in Canada who are a subsidiary of Rogers and who I believe operate as a virtual network operator on the Rogers network.. Everything is working except that it thinks I'm roaming.. On my previous Bold 9700, it showed that I was always on a Home network..

    This is not really a big deal as I'm still able to make and receive calls, but the apps I use for keeping track of data usage (eg Telicost), now always think I'm roaming.. Anyone else see this??
    11-02-10 11:43 PM
  2. Smiley88's Avatar
    I just got an unlocked AT&T-branded 9800 running 6.0.0.246, I'm subscribed to Fido in Canada who are a subsidiary of Rogers and who I believe operate as a virtual network operator on the Rogers network.. Everything is working except that it thinks I'm roaming.. On my previous Bold 9700, it showed that I was always on a Home network..

    This is not really a big deal as I'm still able to make and receive calls, but the apps I use for keeping track of data usage (eg Telicost), now always think I'm roaming.. Anyone else see this??
    don't worry that is just how the unlocked version works. I'm on Roaming too. On Fido it has always show roaming for all my unlocked phones. this includes on BB phones too. You aren't charged for roaming.
    11-03-10 01:34 AM
  3. TLS2000's Avatar
    Must be a Fido thing. My unbranded Torch doesn't show me roaming with my Rogers SIM.
    11-03-10 03:52 AM
  4. f_d's Avatar
    I know that I'm not actually roaming and I'm not being charged despite what the phone says, but my point was that on my Bold 9700, with the same SIM card inserted, the phone reported that I was on my home network (which it is: Fido is a subsidiary of Rogers and runs on the Rogers network as a virtual network operator)

    Although there's no impact from a phone usability point of view, the change in reporting status means that the applications I use for tracking data usage (because data plans still cost an arm and a leg in Canada) don't work correctly anymore.. I think this has got to be a bug in the 9800 radio code or some sort of incorrect provisioning of tables..
    11-04-10 09:37 AM
LINK TO POST COPIED TO CLIPBOARD