1. X04D00's Avatar
    I've had my Torch since around mid November, so it's out of it's original 1 month swap warranty, so I'll have to send it in and wait a couple weeks for a replacement (Canada sucks for that).

    I just want to make sure the problems I'm having are with the phone and can't be corrected myself.

    1. Phone locks up at random (sometimes after being idle, or just turning on, when checking messages, etc.). It will automatically turn off and I'll either see one or two red lights (it varies) and it'll try to turn itself back on (sometimes doesn't, sometimes can't, sometimes reboots while starting up).

    2. The touch screen sometimes works. By sometimes I mean, it might not work, the phone will reboot, and then it'll start working ONLY when the phone is closed. If I slide it open I lose trackpad functionality and touchscreen (though pushing the physical buttons (call/close/click) still work).

    I've tried pulling the battery, wiping all the installed apps, removing the SD card, etc. Nothing works, or even provides a short time remedy.

    Since the touchscreen sometimes works, I'm thinking it might be software rather than hardware. Is there a way to COMPLETELY restore it to the way it was when purchased? As far as I can gather the security wipe doesn't restore it (OS, etc) completely.

    Thanks for any help/advice!
    Last edited by X04D00; 01-08-11 at 04:53 PM.
    01-08-11 04:46 PM
  2. nomi1978's Avatar
    What you could try to do is reload the software through app loader and not restore any apps/configs. When prompted to backup and restore settings select no.

    Also what OS are you running right now. Probably the .246, i would try to new OS posted on the site and see if that helps.
    01-08-11 07:00 PM
  3. aznlgcy's Avatar
    I've had my Torch since around mid November, so it's out of it's original 1 month swap warranty, so I'll have to send it in and wait a couple weeks for a replacement (Canada sucks for that).

    I just want to make sure the problems I'm having are with the phone and can't be corrected myself.

    1. Phone locks up at random (sometimes after being idle, or just turning on, when checking messages, etc.). It will automatically turn off and I'll either see one or two red lights (it varies) and it'll try to turn itself back on (sometimes doesn't, sometimes can't, sometimes reboots while starting up).

    2. The touch screen sometimes works. By sometimes I mean, it might not work, the phone will reboot, and then it'll start working ONLY when the phone is closed. If I slide it open I lose trackpad functionality and touchscreen (though pushing the physical buttons (call/close/click) still work).

    I've tried pulling the battery, wiping all the installed apps, removing the SD card, etc. Nothing works, or even provides a short time remedy.

    Since the touchscreen sometimes works, I'm thinking it might be software rather than hardware. Is there a way to COMPLETELY restore it to the way it was when purchased? As far as I can gather the security wipe doesn't restore it (OS, etc) completely.

    Thanks for any help/advice!
    I'm guessing you're using Bell or Telus. I agree it does suck, don't know why they don't just replace the device like Rogers with a refurb.
    01-08-11 07:03 PM
  4. Bye Berry's Avatar
    Telus used to replace the phone within the first year. I would switch to Rogers if their coverage didn't suck.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-08-11 09:08 PM
  5. Matrix Leader's Avatar
    1) problem one can sometimes be solved by completely wiping your device and reload the same or new OS.


    2) Problem 2 probably needs for the phone to be sent back for warranty.
    01-08-11 09:17 PM
  6. X04D00's Avatar
    Well, it's almost completely bricked now. Pulled it off the charger this morning and used it for a bit. Now it's just a black screen with the image of a battery with a red X across it, and a 3/4 full loading bar at the bottom. It won't charge, either.

    Time to go say hi to Telus and get bent over trying to get a replacement. Good thing I got the protection plan in case they try and blame this on me.
    01-10-11 03:23 PM
  7. moiselles's Avatar
    I think you need to get a replacement. I've had mine since November 8th and have none of those issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-10-11 04:01 PM
  8. Elite1's Avatar
    Well, it's almost completely bricked now. Pulled it off the charger this morning and used it for a bit. Now it's just a black screen with the image of a battery with a red X across it, and a 3/4 full loading bar at the bottom. It won't charge, either.

    Time to go say hi to Telus and get bent over trying to get a replacement. Good thing I got the protection plan in case they try and blame this on me.
    Hi there, you never answered the OS question above. What OS is on the device? Is it 246 that it shipped with, or have you done an upgrade?

    Sometimes a corrupted OS upgrade can wreak havoc like this, so that's why I want more info.
    01-10-11 04:49 PM
  9. papped's Avatar
    Backup your data (only the minimal important stuff, contacts, messages, etc).

    Wipe the phone with BBSAK (should say error 507 after it's done).

    Download the .246 or .337 OS and install it to the PC and load it on the phone.
    01-10-11 05:31 PM
  10. Elite1's Avatar
    Backup your data (only the minimal important stuff, contacts, messages, etc).

    Wipe the phone with BBSAK (should say error 507 after it's done).

    Download the .246 or .337 OS and install it to the PC and load it on the phone.
    This is where I was going, but use Internet Explorer to download the OS. If you previously had downloaded an OS to your PC, delete it first.

    For some reason, a small portion of users have corruption occur when downloading something directly from the RIM site with Firefox or Chrome. (including yours truly...)
    01-10-11 05:43 PM
LINK TO POST COPIED TO CLIPBOARD