1. francees's Avatar
    Torch 98"50" mirrored/inverted screen problem-img-20131109-00162.jpgTorch 98"50" mirrored/inverted screen problem-img-20131108-00140.jpg

    Hi and as you can see in the images i have this Torch 9850 from a friend with this inverted screen problem AFTER HE IVE GOT THE USB PORT fixed/repaired, ive try to DOWNGRADE the OS and UPGRADE the OS with "NO" luck.

    ive searched online for some help and ive came to this forums ; Re: Solution for Blackberry 9860 upside down / inv... - Page 3 - BlackBerry Support Community Forums they claim that the problem would be fixed with an OS downgrade but im not having any luck with that.

    is this an HARDWARE problem? software? flash file?

    P.S. theres also this weird very small hour glass b4 the device start booting up with the blackberry logo ;
    Torch 98"50" mirrored/inverted screen problem-img-20131109-00165.jpg

    even after a full wipe ;
    Torch 98"50" mirrored/inverted screen problem-img-20131109-00163.jpg

    AFTER OS reload ;
    Torch 98"50" mirrored/inverted screen problem-img-20131109-00167.jpg

    OS ver 7.1.0.861

    well looks like ill need to keep trying different OS`s??? this aint fun anymore

    OK after some searching ive downloaded the official sprint OS 7.1.0.163 i "didnt" remove the vender file instaled the OS and when the phone rebooted, i could read the BLACKBERRY logo......

    Torch 98"50" mirrored/inverted screen problem-img-20131110-00171.jpg

    Torch 98"50" mirrored/inverted screen problem-img-20131110-00172.jpg
    Last edited by francees; 11-10-13 at 12:47 AM.
    11-09-13 06:02 PM
  2. AnimalPak200's Avatar
    LOL, believe it or not this is not the first time that I have seen this on this forum. Let me see if I can find the previous thread.

    Here's the thread: http://forums.crackberry.com/blackbe...-issue-718651/

    But I see that the solution they arrived at was the OS downgrade, which you said didn't work.
    francees likes this.
    11-09-13 07:30 PM
  3. francees's Avatar
    LOL, believe it or not this is not the first time that I have seen this on this forum. Let me see if I can find the previous thread.

    Here's the thread: http://forums.crackberry.com/blackbe...-issue-718651/



    But I see that the solution they arrived at was the OS downgrade, which you said didn't work.

    man this is really not cool, would an screen replacement do the trick?
    11-09-13 07:47 PM
  4. AnimalPak200's Avatar
    No idea. Has the screen on the unit previously been replaced? Might be possible that they put it back together upside down.

    Did you make sure that you downgraded to the 'original' OS it came with? Seems like that's what finally made a difference in the support forum and that previous thread.
    11-09-13 07:51 PM
  5. francees's Avatar
    No idea. Has the screen on the unit previously been replaced? Might be possible that they put it back together upside down.

    Did you make sure that you downgraded to the 'original' OS it came with? Seems like that's what finally made a difference in the support forum and that previous thread.
    thats the sad part here, i dont have the box so i dont have an idea whats the original OS it came with.....i do see the SPRINT logo at start up soooo ill try to download some sprint OS and see
    11-09-13 08:04 PM

Similar Threads

  1. Text message problem
    By stevobbm in forum General Carrier Discussion
    Replies: 3
    Last Post: 12-21-13, 09:16 PM
  2. waze - problems after upgrading to os 10.2
    By zivm in forum BlackBerry Z10
    Replies: 15
    Last Post: 11-20-13, 11:14 AM
  3. Data connection problems
    By cheadlender in forum More for your BlackBerry 10 Phone!
    Replies: 2
    Last Post: 11-09-13, 11:16 PM
  4. Blackgram problem
    By Spartiatis in forum BlackBerry 10 Apps
    Replies: 3
    Last Post: 11-09-13, 06:11 PM
  5. Replies: 1
    Last Post: 11-09-13, 12:45 PM
LINK TO POST COPIED TO CLIPBOARD