1. lovinbold's Avatar
    Ok, i've had my Rogers torch for about 2 weeks and i'm going to make a few observations. (mexico 5 .246 os)

    1. the phone is awesome!
    2. minor wobble but expected with a slider
    3. battery life was amazing. 100+ texts and emails, 5-10 2-3 min phone calls, web browsing and some youtube and my battery would last about 40 hours.
    4. webkit is an improvement but can still be made better
    5. speaker is average but no major complaints
    6. touch screen is quick and responsive
    7. phone quality was good, no tin or echo, no dropped calls
    8. I think it's a great phone and to all those negative people looking for some sort of perfection that doesn't exist, create something better!

    Now for the major negative!
    although i think the torch is awesome and from my comments above its apparent that i'm a blackberry lover there is one major negative

    TODAY OUT OF THE BLUE THE PHONE IS DEAD! did a battery pull, read through every post out there, the phone is just fried. it will not turn on. Called rogers and no questions asked they will be sending me out a new one. Even though i'm upset i am not abandoning my torch. I will go back to my 9700 for a few days ( not much of a hardship). Nothing is perfect and obviously this torch is defective. I just hope i get one that has as good battery life and no wobble. keep the faith; i am!

    I just wish i could wipe all my personal info off of it before i swap it but since i can't turn it on i can't!
    10-17-10 02:11 AM
  2. samz's Avatar
    i love my torch
    but i truly miss my 9700

    have you tried reloading the OS?
    10-17-10 02:24 AM
  3. lovinbold's Avatar
    I've tried everything know to man. I cannot get it to do anything. went to app loader to try and force it but the computer can't get it to go. NO red light not nothing! just dead. If you have a suggestion as to how i can force it on to reload a different way im all for it but at this point i guess i'll just use my 9700 and wait for my new torch. it's amazing how quickly we adapt to new phones. I had already gotten so use to the torch i feel weird on the 9700.
    10-17-10 02:28 AM
  4. samz's Avatar
    yeah same here im using the torch everytime i use my 9700 again it feels wrong lol

    mhmm if its dead its dead.. could it be the battery? any friends with the same phone that you can borrow their battery?
    10-17-10 02:39 AM
  5. joeybee's Avatar
    I've had a few issues with mine and ordered a replacement last saturday, still hasn't come. Called Friday and they said it was out of stock right now. Hope mine comes this week.
    10-17-10 02:46 AM
  6. North-Face's Avatar
    That's a bummer, I wonder if it could be just a faulty battery.
    Maybe pop into the closest rogers to see if they have a battery for you to try out.
    I've been a week now with my mex.4 and so far so good. With the gps location off I've gone a bit over 48 hrs with the battery which I wasn't expecting.
    Its a great phone, hope you get your replacement soon!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-17-10 02:55 AM
  7. Thanontos's Avatar
    If it were the battery, when the phone gets plugged into the computer it would be able to do something. Even if it were a dead battery, it would raise question as to why it would not charge it even in the smallest amount. I personally have never heard of a new battery working perfect for a few days and then not being able to hold even a minute charge, but it is likely something inside the phone itself is the culprit. I would use a different charger too on the new phoneif they do not include one. Something wrong in the charger could have caused an issue frying the inside of your phone, small possibility as the cause though.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-17-10 09:41 AM
  8. Chucky1's Avatar
    I'm on Torch #3 as of yesterday. First one was my fault, I lost it. Second one, the day after I received it the buttons around the track pad came off. Now being on the third one, when you press the send or menu key the slider makes a clicking/popping noise. I guess it would be more of a creaking noise in the slider on that one side. We will see how this one goes. #2 and #3 phones were NEW devices and not REFERBS.
    10-17-10 10:04 AM
  9. Thanontos's Avatar
    I'm on Torch #3 as of yesterday. First one was my fault, I lost it. Second one, the day after I received it the buttons around the track pad came off. Now being on the third one, when you press the send or menu key the slider makes a clicking/popping noise. I guess it would be more of a creaking noise in the slider on that one side. We will see how this one goes. #2 and #3 phones were NEW devices and not REFERBS.
    It could be the adheasive they used for the buttons themselves. My first torch did it all I had to do was place my finger on the button and remove it without pressing the button completely. My second torch does it but only on one side, it is annoying, but I got over it after a while.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-17-10 10:34 AM
  10. Chucky1's Avatar
    It could be the adheasive they used for the buttons themselves. My first torch did it all I had to do was place my finger on the button and remove it without pressing the button completely. My second torch does it but only on one side, it is annoying, but I got over it after a while.

    Posted from my CrackBerry at wapforums.crackberry.com
    Mine would not stay on after it came off the first time. Just kinda aggravating when you have a new device with a problem right out of the box. But, it's just a phone...
    10-17-10 12:23 PM
LINK TO POST COPIED TO CLIPBOARD