1. scaglifr's Avatar
    Hi,

    I have a custom SMS tone set for my son. In the options for this tone I have ringer set to "active profile". Yet when I switch the phone to silent or vibrate only profiles the custom tone still plays loudly (the default tone for the profile does not).

    Any suggestions most appreciated.

    TIA

    F
    11-08-10 06:14 AM
  2. bbicons's Avatar
    Reply back with ALL of the settings for this contact alert, for example:

    Notifier Tone:
    Volume:
    Count:
    Play Sound:
    Vibration:
    Vibrate with Ring Tone:

    AND did you want this to just be a custom tone for SMS msgs? or SMS and the Phone Ring tone?
    thanks
    Last edited by bbicons; 11-08-10 at 11:16 AM. Reason: additions made
    11-08-10 11:13 AM
  3. ShadowFlame's Avatar
    I always thought the BB couldn't do custom SMS tones per contact? just ringer sounds and email sounds could be customized per contact, but not sms messages?
    unless the Torch let's you?
    11-08-10 11:16 AM
  4. Qwikhas's Avatar
    Add the custom tone directly to his file is the contact list.
    11-08-10 11:47 AM
  5. bbicons's Avatar
    I always thought the BB couldn't do custom SMS tones per contact? just ringer sounds and email sounds could be customized per contact, but not sms messages?
    unless the Torch let's you?
    Shadow, Being able to modify messages and or Phone seperately is a feature of OS5. If you go into "Profiles" -> Set Contact Alerts -> Add Contact Alert, you will see the option for Phone and Messages. OS6 offers the same options.

    To be wording specific it's ability to modify "messages" overall- not necessarily the SMS vs MMS, email etc. Simply modifying messages (overall) or phone.
    11-08-10 11:59 AM
  6. ShadowFlame's Avatar
    Maybe i am confused but i know with the Curve you couldn't assign custom SMS tones per contact, and looking at the Torch's contact options for to set sound alerts again it just shows "Phone" and "Messages" and as far as i remember, "Messages" just mean emails..
    11-08-10 12:03 PM
  7. ShadowFlame's Avatar
    Wow, ok i was wrong seems with the Torch they work.. didn't work with my 9300 Curve..
    11-08-10 12:15 PM
  8. ShadowFlame's Avatar
    I see what the OP is saying, i set one to a mp3 for a message alert, and it worked fine, set it to "Active Profile" and it played fine when i test texted, but, when i changed my profile to "vibrate" and test what happened was the phone vibrated and as soon as it stopped vibrating it played the MP3 file...
    11-08-10 12:19 PM
  9. Lumute's Avatar
    I have the same problem, I have a custom rington for my wife and even if I put the phone on vibrate only when she calls it still rings that ringtone very loud... maybe this is a new OS6 feature where the contact personality overrides the profile?

    Anyway, I'll try to do some troubleshooting and figure out what is exactly happening, but I will not have time until later. BTW, /I am on 337 and this custome ringtone conf. came from a Storm with OS5, it transferred over when I did the device switch, so it may be a bad configuration that was not properly transferred...
    11-08-10 12:26 PM
  10. ShadowFlame's Avatar
    that kind of sucks, only way to not have them play is "all alerts off" even in "silent mode" they play, in "vibrate only" the phone vibrates and then the sounds play... not exactly being "silent" or "vibrate only"......
    11-08-10 12:28 PM
  11. ShadowFlame's Avatar
    I am on .246 and this is a 4 day old phone, so i don't think it is anything to do with OS5 conf files not transferred over properly, i think it is a big oversight by RIM..
    11-08-10 12:30 PM
  12. the brother's Avatar
    i got the same bug as the OP. the overall SMS sound plays for everyone - the custom one on the contact does not override "Active Profile" even though while testing it on "Try it" it does
    11-08-10 12:37 PM
  13. bbicons's Avatar
    I believe when you change the Contact Alert Profile (for a specific person) to an item that is NOT "Active Profile" it will override and play the setting you select in that custom profile. So if you set a custom sms tone to someone, it will always play that, but if it says "Active Profile", it will use the settings from the selected profile.

    With the way RIM has this set up, it only makes sense to change the "Notifier Tone" and keep Volume, Count, Play Sound, etc on "Active Profile". For example, when you select thhe vibrate only profile it should pull the default settings of (Volume: Silent, with the Vibration turned on). Hopefully that isnt too confusing

    It is confirmed that the Contact Alert Profile Overrides the selected profile. Part of the reason I was asking for the OP to send the settings
    11-08-10 01:36 PM
  14. scaglifr's Avatar
    Reply back with ALL of the settings for this contact alert, for example:

    Notifier Tone: Buffalo_Soldier
    Volume: 8
    Count: 1
    Play Sound: Active Profile
    Vibration: Active Profile
    Vibrate with Ring Tone: Active Profile

    AND did you want this to just be a custom tone for SMS msgs? or SMS and the Phone Ring tone?
    thanks
    Have input the details above : the tone works fine for SMS, email and BBM (all of which is fine ) it is just the failing to go silent when Active Profile is Vibrate Only which is the deal breaker. I'll try changing the Volume to Active Profile and see if it works. Thanks for the help.
    11-08-10 03:52 PM
  15. ShadowFlame's Avatar
    well i tried that, and it worked, looks like you have to leave the volume at "active profile" or whatever level you have the volume set to overrides the selected profile.
    11-08-10 09:28 PM
  16. scaglifr's Avatar
    well i tried that, and it worked, looks like you have to leave the volume at "active profile" or whatever level you have the volume set to overrides the selected profile.
    Have found that when you set the volume to "Active Profile" then the custom tone no longer gets used for BBM : curioser and curioser !
    11-09-10 03:07 AM
LINK TO POST COPIED TO CLIPBOARD