1. nshaw's Avatar
    AT&T is sending out another phone but I thought I'd check to see if anyone has had this before and how they fixed it (short of a new phone). AT&T says it is the phone; however, that doesn't make any sense to me. You'll understand shortly (I hope). Here's the problem:

    1. I can send a text message out and whomever I send it to receives it.
    2. I can send a text message to myself and I receive it.
    3. I DO NOT receive any text messages that anyone else sends me.
    4. I have no problems at all with BlackBerry Messenger. My wife and I use it all the time but my son and daughter have iPhones so texting is the only way to go. According to my daughter who keeps all of her text messages, we texted three weeks ago without issue. That might be when I upgraded to build 695. She also showed me all the text messages she had sent in reply to mine (which I never received). My son also sent a couple of responses to my test messages and I never received those. My wife, who has a BlackBerry, also tried to send me a text message and I didn't receive it.

    I spent 90 minutes on the phone with tech support and another two hours in an AT&T shop without success AND I came home and reloaded the earlier OS without success. I later upgraded to the current release - again, without success.

    The technicians have swapped out the SIM card - no go, problem remains, they have tried my original SIM card in another Torch - no problems at all so it is not the SIM card. They have checked all my Text Message settings - they're correct.

    I cannot see how a hardware issue would prevent using Text Messaging but not affect BlackBerry Messenger or AIM. If they can communicate in and out then so should Text Messages. I'm still thinking it is a settings issue but the settings have been checked and verified on text messages and I've checked the settings on BlackBerry Messenger (there isn't a setting that could cause this as far as I can tell).

    If anyone has had this and was able to resolve it I'd like to know. In advance - thank you!

    Nick.
    10-31-10 10:45 AM
  2. Rickroller's Avatar
    Was a battery pull done after the OS upgrade? Have you checked the Firewall setting? Options > Security > Firewall..make sure the Text Message is not checked

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-10 11:20 AM
  3. Rickroller's Avatar
    Oh..and on a side note..if your kids have iPhones you might want to check out the app Whatsapp. Its a BBM-like alternative of communicating from BB's and iPhones. You can send pics, videos etc and also have the "delivered" and "read" options (Whatsapp uses a green checkmark for delivered and double green checkmark for read). I use that for chat with my wifes iPhone and it works great.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-10 11:27 AM
  4. nshaw's Avatar
    Was a battery pull done after the OS upgrade? Have you checked the Firewall setting? Options > Security > Firewall..make sure the Text Message is not checked

    Posted from my CrackBerry at wapforums.crackberry.com
    I thought I had responded to this earlier but it appears I did not - the problem was, in fact, the firewall setting. I made the change and all is good in BB-land!

    After that, I contacted the AT&T store and AT&T (611) to let them know the resolution for future reference. I wouldn't want someone else to go through what I did. Again - THANK YOU!
    11-05-10 12:45 PM
LINK TO POST COPIED TO CLIPBOARD