1. mricon's Avatar
    hey like an ***** i bought a tester phone (torch) i cant install any firmware on it except i believe pure rim os ones... its stuck at 507 reload software and i cant find these rim os anywhere... any help would be appreciated.
    12-07-10 05:59 PM
  2. pbflash's Avatar
    I don't think you can get them. The only software available on their site is carrier specific. You should be able to load it though using apploader or BBSAK. Just make sure you delete the vendor file.
    12-07-10 06:18 PM
  3. DawgMan's Avatar
    You may be able to download a leaked or carrier specific 9800 OS then load it with either BBSAK (Blackberry Swiss Army Knife) or load it by going to your C drive>Program Files>Common Files>Research In Motion>AppLoader. If you're loading a carrier specific OS make sure you delete the vendor.xml file before loading. Connect the 9800 with a USB cable, double click on AppLoader and run it to install the OS. Do a couple of battery pulls and give it a few days for the OS to settle in. Hope this helps.
    12-07-10 06:34 PM
  4. mricon's Avatar
    tried nothing works... this was a tester phone for rim, i cant get any firmware loaded on this! except i believe a pure rim one
    12-07-10 06:35 PM
  5. mricon's Avatar
    desktop manage thinks there's no updates for this phone and when i use app loader tells me i have the wrong software on my computer... i believe i do need a pure rim os
    12-07-10 06:39 PM
  6. DawgMan's Avatar
    tried nothing works... this was a tester phone for rim, i cant get any firmware loaded on this! except i believe a pure rim one
    Good luck with that...
    12-07-10 06:40 PM
  7. pbflash's Avatar
    The only difference in carrier specific OS's is the vendor file and possibly a few apps. The carriers do not modify the core OS files that they receive from RIM.

    I know I have seen posts by others with test phones that have been able to load other OS's. Maybe posting the steps you are taking and the errors you are getting would make it easier for someone to help you.
    12-07-10 06:43 PM
  8. mricon's Avatar
    okay well the phone came with a really slow firmware, I wiped the phone with bbsak... tried using app loader to install the new firmware detects pin and everything... but then it says cannot find correct software for your device or something. i tried so many different firmwares. when i try to request a software update through dm says there is none for my device... and also in the dm screen it shows my device as unknown but it does show the pin detected. i tried it on 2 diff laptops and iv flashed os on my 9700 all the time so this is nothing new to me
    Last edited by mricon; 12-07-10 at 06:52 PM.
    12-07-10 06:47 PM
  9. VZWman1987's Avatar
    What kind of computer are you using?
    12-07-10 06:52 PM
  10. pbflash's Avatar
    Did you delete the vendor.xml file before trying to load it? Did you make sure you only have 1 version of the OS installed on your PC?
    12-07-10 06:54 PM
  11. mricon's Avatar
    yes i did delete vender.xml and yup i made sure i only had 1 version of the os installed. vzwman im running on windows 7 dual core 2.1ghz intel board... and the other laptop was running vista
    12-07-10 06:57 PM
  12. shansmi's Avatar
    This should work fine. Flashing a beta device should be like any other. If trying to use DM6, unhook your internet connection. You might try the nuked bb recovery proc over in the how to section. It deals with starting the device with no battery...

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-10 07:48 PM
  13. TLS2000's Avatar
    Ya, you should have no problems flashing the device unless it has a hardware problem. My device is a RIM branded device as well and I have no issues with software updates.
    12-07-10 10:28 PM
  14. sushtsi's Avatar
    Try calling RIM?
    Last edited by sushtsi; 12-22-10 at 11:01 PM.
    12-21-10 12:36 AM
  15. dictoresno's Avatar
    my guess is that the VSM loaded on the phone, most likely an engineering one from RIM, is preventing OS from being loaded. it may block all current OS releases, and will only allow an OS properly coded for that specific VSM/Vendor ID. kind of the way the vendor file prevents you from loading an OS unless it detects the correct Vendor ID in the phone. obviously, we get around this by deleting the file. the OS you are attempting to load (a normal OS) may be missing a special file that only RIM engineers had access to. this would render stolen engineering units paperweights if they got stolen or if someone tried to load a new OS.
    12-21-10 12:52 AM
LINK TO POST COPIED TO CLIPBOARD