1. SWFLFFPM's Avatar
    I just got my Torch yesterday. I downloaded my calendar and contacts from my home computer before setting up email.

    I set up email for my work email address. I do not want my home email on the Torch. This creates another calendar named <my work email address> and also creates duplicate calendar entries. The problem is I use an app (Pocket Informant) that only syncs with the default calendar. I switched to just the default so I'm only seeing one entry-no duplicates.

    I won't be using my work calendar or contacts on my BB.

    I don't want two calendars on the BB as I'm afraid something will get missed.

    Ideas?
    11-27-10 09:09 AM
  2. Don_Henry's Avatar
    Hey SWL . . .

    I had the same problem and here is the fix:

    First of all - my operation configuration (so you can compare) -
    * I am on BIS (company does not have BES yet)
    * I only have work email on my device
    * I sync calendar and contacts using Desktop Manager 6.0

    1) What to do everytime AFTER syncing with Desktop Manager
    * After syncing, open CALENDAR
    * Hit the menu key, and select OPTIONS
    * You should then see DEFAULT and WORK email calendars
    * Highlight the WORK EMAIL
    * Using the physical keyboard, type the word "move" (no quotes, lower case) - [note you will not see any characters on screen when you type it]
    * You will be prompted do you want to move all default enteries into your work email - answer yes
    * Close CALENDAR and then re-open - you should now see only entries from your WORK email

    2) What to do everytime BEFORE you sync using Desktop Manager
    * Connect your 9800 and open Desktop Manager
    * In the uppper left corner you will see a button named DEVICE
    * In the DEVICE pull down list, select DELETE DATA
    * In the DELETE DEVICE DATA screen, select SELECTED DATA
    * From the list, select to delete CALENDAR and CALENDAR ALL
    * After confirmed deletion, close the Delete Data function and now you can go back to sync

    Doing Step 2 will ensure that old calendar entries from the Default calendar are removed from your 9800

    3) The other thing to check:
    * Under OPTIONS->DEVICE->ADVANCED SYSTEM SETTINGS->SERVICE BOOK . . you should see two listings with your work email address. Click them both - one should say CICAL (calendar) and the other one should say CMIME (email). DO NOT DELETE EITHER OF THESE.
    * Check all the other service books - if you see any other service books with CICAL or DEFAULT CALENDAR in them (this would be the default calendar), DELETE it by hitting the MENU button from the highlighted service book you want to delete, and then selecting DELETE. (After clicking and opening the service book, you will have to use the BACK button to get back to the service book listing - the default calendar service book should then be highlighted).
    * You will only have to delete the service book one time only.

    I hope this solves your problem.

    DonH
    11-27-10 10:03 AM
  3. SWFLFFPM's Avatar
    Thanks. I also went here:Getting rid of MULTIPLE calendars - BlackBerry Support Community Forums and followed the links in that post. It appears to be a permanent fix.

    This has worked so far but I'm having sync issues with double entries, mismapping of fields etc.
    12-02-10 05:37 AM
LINK TO POST COPIED TO CLIPBOARD