1. jmee2007's Avatar
    Soooo, I have an unlocked Torch for Tmobile and for some odd reason, my buttons and keypad stops working! The only way I can get this to work is by removing the battery, putting it back in and hoping the keys will work the next time. I have dropped the phone only ONCE, and it was on CARPET, so the impact shouldnt have been that hard to have caused this problem. PLEASE let me know if anyone else has had this problem or if there is a way I can fix it. Or maybe if I should send it back under warranty.

    THANKS!!!!
    09-23-10 11:39 PM
  2. mark_rivers19's Avatar
    good news is yo ure still under warranty..
    if you are within 30 days you can get an exchange from where you bought it..
    if you are past the 30 days.. it's still covered under the 1 yr standard manufacturer's warranty
    09-23-10 11:43 PM
  3. yabo730's Avatar
    i keep having the same problem. i noticed that it happened after after taking it out from my case. so after some internet digging it seamed that everyone having this problem was like me, using the wrong case, i was using my old curve case, then i tried a t-mobile case same problem. when i went and got a case made just for the torch the problem stopped, the guys at att told me that they had a lot of returns due to this problem, when i told them what i did to fix it the manager gave me a free car charger lol...
    09-24-10 01:07 AM
  4. belfastdispatcher's Avatar
    My wild guess would be the Torch needs a smaller magnet, maybe a warning should be put up about it to stop other people making the same mistake and give the Torch an undeserved bad name.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-24-10 04:15 AM
  5. jcp007's Avatar
    Try the OEM leather holster or pocket pouch.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-24-10 07:16 AM
  6. jmee2007's Avatar
    Oh WOW!! Thats all it was??? Well now it works fine!
    Thanx for sharing!
    09-29-10 01:31 AM
  7. ckinglam's Avatar
    I am using the OEM leather pouch for Torch and I am still experiencing the same problem. Can anyone confirm if its something else?
    11-19-10 03:23 AM
LINK TO POST COPIED TO CLIPBOARD