1. chaddeus's Avatar
    I am in Singapore and I got a prepaid SIM card. The country code is +65 and I input friends number on my phone book as +65 1234567. However, when that person called, my caller ID shows 1234567 without showing me the name of the person inside my phone book. Its like as if the number isn't in my phone book.

    The only solution to that I actually store their number on my phone book without the country code.

    I read somewhere you can change the settings but I forgot how. Help please.

    - Charles

    Posted from my CrackBerry at wapforums.crackberry.com
    02-01-11 06:28 AM
  2. homer1475's Avatar
    I don't know how it works over there, but do you need the country code when dialing locally? If you don't why use it? Since you said when you store numbers without it they show fine.
    02-01-11 07:09 AM
  3. jeffh's Avatar
    Phone / Menu / Smart Dialing takes you to where you can enter your country code.
    02-01-11 07:11 AM
  4. jessassej's Avatar
    Its works fine for me on post paid sim with or without +65. Try +651234567 (without the space in between the country code and phone number), it might work!
    02-01-11 09:26 AM
  5. khato's Avatar
    I am in UK and have contract sim. Iget the same p[roblem without the international dialling codes prefixed to the phone number.
    Any ideas ppl? If I had known all these bugs then I honestly would not have gone for the Torch. I would have considered iPhone or Galaxy
    02-01-11 11:10 AM
  6. chaddeus's Avatar
    On the OS 6, its under Options > Call Management > Smart Dialing...

    Make sure you have the proper area code and the national number length.

    Thanks everyone for your help.

    - Charles

    Posted from my CrackBerry at wapforums.crackberry.com
    02-01-11 09:21 PM