1. badrep's Avatar
    As soon as I leave the city my phone goes into SOS and no service..

    Called telus and they are saying its probably the phone because those area's have good towers...we tried battery pull, checked the mobile network options and everything seemed fine..

    I cant even return my phone because I bought it unlocked from someone online so no warranty (not for sale version)

    personally i dont think anything is wrong with the phone because it works perfectly in my city in Canada.

    I dont think its anything with telus either unless their is a frequency signal or and update that my phone is missing..

    my guess is that its probably some kind of setting issue but im not sure

    has anyone else had this problem??

    please help!
    10-23-10 03:35 PM
  2. carullo's Avatar
    what phone ????
    10-23-10 05:14 PM
  3. maxiang's Avatar
    Do you have any friends with GSM phones on Telus to help you confirm? You're obviously getting some signal as SOS means you can make emergency calls, whereas an X would mean no signal. From what I've heard, Telus and Bell do not have 2G networks to fall back on and have roaming agreements with Rogers so maybe your phone is not setup to roam properly.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-10 05:30 PM
  4. mohawk apple's Avatar
    *--
    Do you have any friends with GSM phones on Telus to help you confirm? You're obviously getting some signal as SOS means you can make emergency calls, whereas an X would mean no signal. From what I've heard, Telus and Bell do not have 2G networks to fall back on and have roaming agreements with Rogers so maybe your phone is not setup to roam properly.

    Posted from my CrackBerry at wapforums.crackberry.com
    how do you set it up rite to roam properly?
    thanks
    10-23-10 06:40 PM
  5. rethcork's Avatar
    Regardless of what you have tried so far, try this;

    A full security wipe, then resend the service books from the Telus BIS screen. I've had issues like that before and doing those two things put the roaming information that my carrier uses.

    Hope that helps?

    10-24-10 12:51 PM
  6. shansmi's Avatar
    This is a beta device. Any idea for what network? What OS? Under mobile network options, is it set to 3g and 2g?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-24-10 01:37 PM
  7. badrep's Avatar
    Hi Guys thanks for your help so far...

    Just to clear up some questions: Torch, os .246, network mode set to 3g
    data services on, while roaming on, mobile network telus, network selection automatic

    Rethcork how do you do a full security wipe (does that mean a full reformat?)..

    My friend was with me on the 2g network with Telus, his was working fine but that doesnt matter because were on different networks..

    It is actually x and sos at times cant make emergency calls either

    Telus has a ticket open on this and im supposed to hear back by wednesday

    please keep the ideas coming

    i will keep you posted with telus's feedback
    10-24-10 04:01 PM
  8. TLS2000's Avatar
    If you have an X there is no cellular service available in your area. If you have SOS you are picking up the Rogers GSM or UMTS networks. Telus has no service where you are having issues. They're lying to you because they know that you can't do anything about it.

    Edit: Telus and Bell do not have roaming agreements with Rogers. If you have no UMTS signal from them, you will not roam on the Rogers network.
    10-24-10 04:25 PM
  9. bluedimness's Avatar
    I actually had the same problem about two days ago when I left the city. The connection came back eventually but it was out for a good 10-20 minutes. I was in a restaurant so I don't think the phone switched towers or anything. My friend who also has a torch and is on Telus was sitting beside me as well. He didn't seem to have any issues. Very weird.
    10-24-10 04:50 PM
LINK TO POST COPIED TO CLIPBOARD