1. ennx's Avatar
    I have two hosted Gmail accounts. I cannot receive mail from either one in my Torch inbox. I get notification of new messages, but nothing in the inbox. I did an advanced search of the mail app and found all the missing messages. I have no idea what folder they are in. From what I can see this BB doesn't tell you the folder these messages are sitting in when you search. When I do a folder by folder search I find nothing. So two questions for anyone who can help.

    1. Where are these messages residing?
    2. Why are they bypassing the inbox (there are no filters of any kind)
    10-17-10 10:23 AM
  2. jeffreii's Avatar
    Are you looking for them in the messages app? Or in the actual mailbox icons that are called "account@gmail.com"?
    10-17-10 10:51 AM
  3. ennx's Avatar
    I'm searching in the Messages app. I don't know what you mean by "the actual mailbox icons that are called "account@gmail.com"

    I'm not using the Gmail app, if that's what you mean.
    10-17-10 10:54 AM
  4. shansmi's Avatar
    The mailbox icons are hidden by default. If you look in the Messages > Options > Inbox Management you can turn off and on what appears in the Messages folder. If you turn them off there you will have to unhide the individual account mailboxes by doing BB Menu > show all while on the homescreen. At that point uncheck the "hide" option for each inbox with it selected from the BB Menu.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-17-10 11:32 AM
  5. ennx's Avatar
    When I open Messages > Options > Inbox Management all I see is my two Gmail accounts with checkmarks beside them. There is no way to do anything else in there except check off Text Messages, if you want them in the inbox.
    10-17-10 11:49 AM
  6. jeffreii's Avatar
    I don't know why they're not showing up in the messages folder if they're checked...

    For each email associated with your device there should be an icon for it. Mine are hidden since I use the messages folder and don't need to see a folder for email only. Instead of being called "messages" the icon is called i.e. "rje@gmail.com". The icon is the same as the messages icon except that it has a browser symbol on the bottom of the envelope. You might need to select "show all" from the options menu on the homescreen to see the icons if they're hidden.

    I wanted you to check that folder and see if your mail was showing up there - because if it's not, there's a problem with your BIS/email account.
    10-17-10 12:42 PM
  7. ennx's Avatar
    Yes I have email folders for the two accounts. They do not receive mail for my two accounts.
    10-17-10 01:17 PM
  8. jeffreii's Avatar
    First try re-sending your service books.

    Then you might want to try deleting those email addresses from your BIS and then re-adding them if it still doesn't work.
    10-17-10 01:22 PM
  9. ennx's Avatar
    I've done that. I've done multi-battery pulls. I've done all the BB tricks. I get notification and I can find the mail on an advanced search. Where it is is a mystery and why it won't appear in the inbox, a bigger mystery.
    10-17-10 01:24 PM
  10. jeffreii's Avatar
    Was this working fine before and suddenly stopped working?

    Have you tried un-checking the box, save, go back in and recheck it?

    At some point if you can't figure this out it might take an OS wipe but I hope not...
    10-17-10 02:14 PM
  11. ennx's Avatar
    This is my fourth Torch. I'm a journalist and I test and review them. It has been the same on every Torch. I never experienced this with the 9700 or any prior Blackberry.
    10-17-10 02:40 PM
  12. Rickroller's Avatar
    This is my fourth Torch. I'm a journalist and I test and review them. It has been the same on every Torch. I never experienced this with the 9700 or any prior Blackberry.
    If this has happened with ALL 4 of your Torches..then i've got to say it's user error somehow. I have a gmail account (as do numerous others) and everything is normal..they show up in my messages folder and I have my @gmail email folder along all 4 of my other email accounts.
    10-17-10 02:45 PM
  13. jeffreii's Avatar
    Wow. How did you walk out of the store with the 4th phone and not get them to prove that it could show your emails? lol

    Did you use the device switch wizard to transfer your 9700 settings to your 9800? If you've had this one multiple phones - and you are receiving the emails, but they don't show up in the right place - there must be some setting somewhere that is messing this up.

    I'd bet that if you did an OS wipe and didn't restore anything - just made sure your email was set up - that it would work fine...

    I'm not sure what else to try at this point - you've done all the normal stuff.
    10-17-10 02:45 PM
  14. ennx's Avatar
    An OS wipe will accomplish nothing. I started out with 4 brand new Torches.
    10-17-10 02:51 PM
  15. kwkid's Avatar
    I've been following this post since it started. All the advice is spot on and I have to agree that it isn't a phone issue. I would wipe the phone and start from scratch. The first thing would be to setup the Gmail and have someone send you a test message. Hundreds, if not thousands of Torch users, myself included, use Gmail and I have not heard of this issue. The fact that you have had four Torches leads me to believe it is not a phone or carrier issue. Should you decide to exchange the phone again, I would set up the Gmail while at the store and test it thoroughly prior to leaving. Virtually anyone in the store can send you a test email without any issue.
    10-17-10 02:54 PM
  16. jeffreii's Avatar
    An OS wipe will accomplish nothing. I started out with 4 brand new Torches.
    So you didn't use the device switch wizard or restore settings from a backup of your 9700?
    10-17-10 03:13 PM
  17. ennx's Avatar
    I didn't use the device switch wizard. To people asking me why I didn't test it in the store. I get my phones from RIM. I haven't been dealing with a store. I have had Telus delete my BIS and set it up again. That doesn't help. I'm on the phone now with Telus Blackberry Support. They've been working on this for a week, and they can't figure it out.
    Last edited by rje; 10-17-10 at 03:26 PM.
    10-17-10 03:23 PM
  18. shansmi's Avatar
    The OS is important. I see nothing stating the OP is running 246. That should be checked and updated if necessary. I would do a wipe and only configure email. Once email is working finish setting up the device to your liking. BTW if email is in "Messages", it is also in the individual inboxes. Messages is just a way to see everything in the same place...

    Posted from my CrackBerry at wapforums.crackberry.com
    10-17-10 03:24 PM
  19. ennx's Avatar
    .246. All Canadian Torches come delivered with .246. There is no mail in any individual mailboxes that I can find. I do find all the missing mail when I do an advanced search in Messages.

    *I am now getting mail in the inbox from one of my Gmail accounts. Not the second one. This is since they reset the BIS.
    Last edited by rje; 10-17-10 at 03:29 PM.
    10-17-10 03:27 PM
LINK TO POST COPIED TO CLIPBOARD