1. cdn12Gauge's Avatar
    (Please note, this is probably a Carrier issue, not the phone itself)

    Hmm, got a Torch on the 11th thru Bell, it was a hardware upgrade.

    Everything is done but no Blackberry server connection icon next to the "3G" and signal strength in the upper right. Retailer tells me it may take up to 24 hrs to register. Not able to do any internet activities.

    Wait 24 hrs (at least) and return to retailer, they call tech support, and a ticket is created. Still no server connection. At this time I'm directed to go thru Mainscreen>Options>Device>Advanced System Settings>Host Routing Table> there are no entries here. Pressing Menu key allows me to select "Register Now". Registration is sent. Then directed to soft reset (remove battery, sim card, wait 5 minutes, power up) still no internet.

    The retail staff at this location is not very familiar with the Torch and don't have many suggestions. Bell tech support escalates the problem and gives me a ticket and suggests it may be solved within a few hours or the next day. Its Friday night at 8 pm, lol. After a few calls by Monday new Bell tech supports confirms that A) tech support doesnt usually works weekends, and B) that no one has even looked at the ticket yet, they are in a que system. I would have been happy (I mean less upset) had I been told this.

    Yesterday go to a different Bell location, employee there had a Torch and was very helpful, suggests a few things, also suggests DOA the phone and replace it (other issues out of the box, camera pictures did not display when you selected the thumbnail for pictures in the lower left of the camera screen, phone screen goes black immediately when tilted while in call, and the keys below the touchscreeen simply wouldnt respond when pressed (the retailer observed this))

    I go today and spend 2 hours at this location with another extremely helpful employee. The phone is replaced, the sim card is replaced, the contract is reset, the employee is on the phone (himself) with tech support for 1.5 hrs.
    We swap sim cards with another Torch, I have the same problem in the other phone, and my phone connects to the server with the other sim. Thru this I was informed that Bell had issues with sims ending in "007" (bond, anyone?) and "009". Both sims I have now have had end in "020"

    So one week so far and still no answers and no internet, cant even set the phone up to recieve email. Curiously I can download stuff from Appworld, not sure how that gets on my phone without the net.

    Anyone have any ideas whats going on here? Have the same problems? Tried to post all relative info, sorry if the post is too long.
    11-18-10 11:14 PM
  2. zoom--zoom's Avatar
    do you have 2 hours spare ? try wipe everything from the phone install new OS, then see what happen....
    If the phone dosent recognize the Service provide it is because
    1.The sim is faulty
    2.The Phone is faulty
    3.The OS it has a bug and is broken.

    If non of them works the is something about you plan because is imposibile to download from appworld without a data plan or the Network is on even if you have wyfi you cant download from appworld via phone/device.


    I have Bell to and i had iphone4 before the torch and i just put the sim inside and bom Data+3g. no w8ing no nothing but after a while i realize i have to haveBB data plans and i switch to a BB data plan

    Here is the link fro you new OS
    cdn12Gauge likes this.
    11-19-10 12:19 AM
  3. shansmi's Avatar

    no wipe is necessary yet....

    Have you ever had a BB before? Try going to your carriers BIS website and creating an account. From there under help, send the service books after you link the account with an IMEI.

    Try this...

    Last edited by shansmi; 11-19-10 at 01:38 AM.
    cdn12Gauge likes this.
    11-19-10 01:26 AM
  4. cdn12Gauge's Avatar
    @ zoom-zoom: Hmm I downloaded the new OS, forgive my ignorance, but when I run the Desktop Manager (v6.0.0) and select update, it says no update is required for this device. It's operation with v ...0.246 so it can be updated with v ...337. How do I do this?

    @ shansmi: Did what you suggested but wont allow me to register until the unit is registered on the network (directs me to the same "register now" location I described in my OP) so I can't get in to try to get the service books. This is my 4th Blackberry, and its starting to remind me of the Storm, grrr... (although it seems to me to be Bell is the problem, not the hardware)

    Also I did wipe the previous device, and this had fixed the "no camera picture display" I mentioned in the OP. Thanks both for replying, and advice on how exactly to install the new OS on my phone would be appreciated.

    Based on everything that was tried and checked today at the retail outlet, the only conclusion I can suspect is perhaps the sim cards ending with "020" are faulty like the "007" and "009" ones the Bell tech suggested.

    Some other stuff:

    I did download "Copter" game from Appworld, and it works, stupid fun timewasting game.
    Sent my friend an invite for Blackberry Messenger, via his PIN, and he did NOT recieve the invite
    My SIM card was put into a BB 9700 and was able to use Google and other internet functions normally, but not in another BB Torch (same problems as with my Torch)

    I can't understand how I can get stuff from Appworld, but not facebook, regular internet, BB Messenger
    Last edited by cdn12Gauge; 11-19-10 at 02:16 AM. Reason: added more info at end
    11-19-10 02:06 AM
  5. chaddeus's Avatar
    I assume you did not shrink your OS, removing the OTA upgrade right?

    - Charles
    11-19-10 02:13 AM
  6. shansmi's Avatar
    Your welcome. When you login, do you see the correct IMEI and PIN?
    11-19-10 02:21 AM
  7. cdn12Gauge's Avatar
    @ chaddeus: huh? I got the "OS", but whats a OTA, lol? Basically, I DL the new version, it installed Blackberry Desktop Service v6.00 on my comp, but can't find where in the Desktop service I would install the .337 update software. It tells me my device has no new software updates available.

    @ shansmi: I was able to get the correct PIN and IMEI from the device itself, but as of this point not allowed to complete the registration on my carriers BIS website because the device has not been registered. I'm off to bed now anyways.

    Small apology, this is all new to me, please bear with me.
    11-19-10 03:42 AM
  8. zoom--zoom's Avatar
    Fallow the instruction..

    Plug in your phone and use Desktop Manager 6.0 (DM) to make a backup of your device. Also make sure your BBM backup settings are enabled - registered email for remote backup and do a local backup too just in case - look in BBM options.

    Close DM and:

    Uninstall any OLD BlackBerry OS versions from your computer if you have them. You can find your installed programs in Windows by going to control panel/programs and features. You're looking for "BlackBerry Device Software".

    Install .337 to your computer. This means you double click on the OS.exe file that you downloaded and let Windows install it.

    C:\program files(86)\common files\research in motion\apploader\

    From there delete vendor.xml, if it's there, then run loader.exe

    Follow the instructions - make sure you look closely at the list of items that have or do not have check marks next to them so you install what you want and don't install what you don't want.

    When the popup asks if it should make a backup of your device and restore your 3rd party apps, it should be selected to do it. Do not change it.

    Wait about 15-20 minutes for the process to complete and your phone to reboot completely before disconnecting.

    Enjoy and let us know how it went. Always remember it takes several battery pulls while you're getting your phone running again before the OS becomes stable. If it seems slow at first just give it some time to do it's thing and when it seems to have caught up, do another battery pull.

    Good luck and feel free to PM me if you have any trouble!
    11-19-10 12:28 PM
  9. Mick70RR's Avatar
    I had a similar problem with a new phone and this worked for me. It also worked for a friend of mine when their phone came back for repair and wouldn't register.

    Remove the battery and the SIM card, then replace just the battery and let the phone power up.
    Remove the battery again, replace the SIM card, replace the battery and let it power up.
    Go to Host Routing Table>Options and select Register Now.
    11-19-10 01:23 PM
  10. cdn12Gauge's Avatar
    Well, the solution was to return to the Bell outlet tonight, and completely wipe my account and plan and re-enter it. I thought they did this yesterday but I guess not. And Voila, phone works 100%. Finally have internet.

    From what I understand the reason I could download Apps was because the phone defaulted to the Pay-per-Usage billing and didnt use any data. Should be an interesting bill, I really didnt get much and they have already said they will reverse the charges.

    And a big thank you for everyone who responded and @zoom-zoom I will follow your instructions and install the new OS, maybe tomorrow night.
    Last edited by cdn12Gauge; 11-19-10 at 10:22 PM. Reason: typos
    11-19-10 10:19 PM
  11. shansmi's Avatar
    Glad things are working but that does not really explain why your account (IMSI) worked in another BB. When the SIM was in the 9700, did it see BIS meaing was there a BB symbol beside 3G or did it say EDGE?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-19-10 11:24 PM
  12. cdn12Gauge's Avatar
    shansmi, when the sim was in the 9700, I did not see the BB symbol next to "3G", as I was looking for it, however, it may have said "EDGE" I am not sure as I wasn't aware it had some significance. The retail employee was the one who connected to the net on that device and showed me a successful google search and stated the internet worked on that device with my SIM. But I do recall there was definetly no BB symbol.

    Hmm what am I missing? DL the new OS, extract it and all it does in install the BB Device Software manager for my computer. I cannot find the OS.exe file, where do I look for this? I did find the Apploader folder and ran it, but need to install the OS first. The DL only installs the desktop software for me. Checked control panel and no previous BB OS were installed.
    Last edited by cdn12Gauge; 11-20-10 at 12:06 AM. Reason: demonstrating my ignorance
    11-19-10 11:48 PM
  13. shansmi's Avatar
    For upgrading the OS you do not need the DM. Easiest way to find it is download the file again. When prompted for a location, note where it comes up by default. Go there manually and see if your previous download is there. If it is drag it to your desktop and cancel the second download. If it is not there you can either search for it (windows search) or just download it again. Run that installer and just use the apploader.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-20-10 12:43 AM