1. superdork21's Avatar
    I was wondering if anyone had the same problem I had. I loveeeeee my torch, and i'm always on it since i've gotten it last week. I loaded up .246 and everything is good to go. Except my wife just returned hers cause it appears that her calls on the handset sounded like someone was speaking from far away (compared to mine). Now, when I make calls I realize that even on level 10 volume, it's not loud enough! Sometimes even the sound gets a little echo-ey and becomes hard to understand the person, especially outside!

    Anyone else have this problem?
    10-10-10 10:16 AM
  2. ekbeegl's Avatar
    Look at my posts have the same problem

    Yep same issue, still no resolution.
    My volume was actually really loud when I first got it. And has slowly gotten lower,I used to have it on like 5 and it was loud enough, now 10 is low

    Cleaned out the ear piece, tried all the different os upgrades...and no resolve. Going to call it in for exchange and see it that helps
    10-10-10 10:22 AM
  3. superdork21's Avatar
    We'll see how my wife's new handset is like when it arrives next week. If theres any change in her volume I guess I should change mine over. Except i'm dreading Rogers support since they wasted 5 hrs of my life for my wife's phone return.
    10-10-10 10:28 AM
  4. jnb903's Avatar
    same problem with the sound. I think it was the last update. Sound was better 4 weeks ago when I got the phone and now I have a hard time hearing on 10
    10-11-10 10:33 PM
LINK TO POST COPIED TO CLIPBOARD