1. Roadrunner604's Avatar
    I purchased the Torch the day after Launch Day for the Torch in Canada from the local Telus store. I have had it for just over 24 hours now and experienced a few issues:

    (1) My telus.blackberry.net email addresses could not be added to the device; a call to Telus technical support resolved this issue. Apparently there can only be one "email profile" on the Torch and I had messed it up by creating one for gmail and another for telus.blackberry.net email addy (kind of a weird explanation I know). The rep had to 'reset' my email settings.

    (2) I performed back up and restore via Desktop Manager (had a Tour before). Gmail inbox was loaded onto Torch via this function. The Gmail inbox started to act up. In areas of low signal strength (and at various other times too), I could NOT send emails nor delete emails from "mailbox and handheld". I had to delete my gmail inbox and re-add it back. It seems to work fine now after that.

    (3) My browser worked for the first few hours but stopped working halfway through the day. I thought it was a Telus technical support issue but did not have time to call again. So during a few spare moments, I turned mobile connections off, and then turned back on. Voila - browser seems to work now. Also, this is my first 3G+ phone, but the browser speeds don't appear to be any faster than my old CDMA phone (Tour)...is this normal??

    (4) Whenever I get high email volume in my gmail inbox, accessing it through the touch screen seems to slow the whole OS down. I found that it slows/freezes less if I slide the keyboard open first and access the inbox via clicking the trackpad. This seems really weird. Has anyone else experienced this??

    (5) I had to yank the battery twice in 24 hours to reset the Torch because it was slowing down (like my old Tour). I thought with OS6, I would not have these issues anymore. Overall, the OS seems sluggish and I would frequently get the black clock dial (just like on my Tour) and especially when using BB App World.

    (6) Battery life - had a full night's charge...and it barely lasted 12 hours under modest use and not any longer than my old Tour.

    (7) Google Maps - Find it difficult to get an accurate fix on my location. How can my friends stalk me on Latitude if I am only "accurate" to within 1900 metres??? Not to mention the frequent black clock dial showing up while using Google Maps and Latitude...very annoying.

    Anyways, so far....impressed with the hardware....touch screen is actually decent....slider is solid. But software/OS needs work and not convinced this device with OS6 is any better than my old Tour or even a Bold.

    Would love to hear feedback from other Canadian Torch owners!

    Thanks!
    10-03-10 03:15 AM
  2. grahamf's Avatar
    (5) I had to yank the battery twice in 24 hours to reset the Torch because it was slowing down (like my old Tour). I thought with OS6, I would not have these issues anymore. Overall, the OS seems sluggish and I would frequently get the black clock dial (just like on my Tour) and especially when using BB App World.

    (6) Battery life - had a full night's charge...and it barely lasted 12 hours under modest use and not any longer than my old Tour.

    (7) Google Maps - Find it difficult to get an accurate fix on my location. How can my friends stalk me on Latitude if I am only "accurate" to within 1900 metres??? Not to mention the frequent black clock dial showing up while using Google Maps and Latitude...very annoying.
    All this seems oddly connected...
    10-03-10 03:35 AM
  3. Roadrunner604's Avatar
    What do you mean?
    10-03-10 03:42 AM
  4. grahamf's Avatar
    Well most people seem to be having no problems with the Torch, and at least two of your points sond like a bad app has been left running and it's consuming a lot of system resources.
    10-03-10 04:39 AM
  5. FineWolf's Avatar
    Well most people seem to be having no problems with the Torch, and at least two of your points sond like a bad app has been left running and it's consuming a lot of system resources.
    Yes, I agree. Navigate to Options > Device > Application Management and check the CPU & Memory tabs. See if an application is using more then it should (you can also check the "This Week" sub-tab if nothing pops up).
    10-03-10 07:36 AM
  6. MusicMtl's Avatar
    I also have a Torch on Telus and am not experiencing any of these issues. I use Google Maps, and it is working fine, though am not using Latitude. Re: issue number one, I have 5 email accounts and no problems at all. Re: #2, after reading many people's comments about not using device transfer, I decided to do a clean install when I received my Torch. Looks like it was good advice! Apparently some old data (not compatible with Os 6) comes along for the ride if you do a transfer and causes various random issues.

    About battery life, I am a heavy user and the battery has lasted all day so far, every day since last Thursday. I am very impressed with this phone to date!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-03-10 09:04 AM
  7. carey965's Avatar
    Ya no issues here

    I bought mine at 10am thursday morn from my local telus store I even did thhe device switch wizard (but did not select the option for the apps and just installed them again) only did 1 battery pull which actually I didn't even need to do cause I found out after that I was just not pushing my convience key in all the way

    Battery last me all day never been below 35% and that's with wifi and bluetooth on and constantly playing with my phone cause I can't keep my hands off it. This is actually the 1st phone that I will actually keep for my entire contract and not upgrade halfway through

    I would maby suggest a reinstall of the os and only use the device switch for the important stuff like you contacts and msgs

    Posted from my CrackBerry at wapforums.crackberry.com
    10-03-10 09:17 AM
  8. Rickroller's Avatar
    No issues here

    Telus Torch..bought on release day. Mexico 5 build. After reading numerous posts, I too opted out of using device wizard and actually used Google Sync for my contacts, and then manually transferred over my email/sms/bbm contacts and history, calendar, phone history, memo's etc and then re-downloaded all my apps manually. Other than having to do an initial battery pull to get my BIS working, all's been great except for battery life.

    First day I got maybe 3-4 hours from a full charge to 30%. I charged it for an hour and a half up to full and only got another 3-4 hours out of it till 30% again. Left on charger overnight and went from 6:30am til 4pm with moderate usage..which was an improvement. Guess i'll see how today goes..as it does seem to be improving. If not..meh..guess I'll get a different battery.
    10-03-10 09:26 AM
  9. Mikey52's Avatar
    I'm sorry to hear you're having these issues. I got mine through Telus on launch day and its been perfect. Without getting into too much technical speak..I'd say bring that one back and get a fresh one!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-03-10 09:30 AM
  10. cestlavie77's Avatar
    Ya no issues here

    I bought mine at 10am thursday morn from my local telus store I even did thhe device switch wizard (but did not select the option for the apps and just installed them again) only did 1 battery pull which actually I didn't even need to do cause I found out after that I was just not pushing my convience key in all the way
    I'm so glad I'm not the only one who was having the convenience key issue. Although I must admit that after a couple battery pulls I actually took it to my Rogers dealer and said my convenience key was defective. He pushed it and it worked right away. I felt a little silly! It takes a lot more to push this one than it did on my Bold 9000.
    10-03-10 09:55 AM
  11. Rickroller's Avatar
    I'm so glad I'm not the only one who was having the convenience key issue. Although I must admit that after a couple battery pulls I actually took it to my Rogers dealer and said my convenience key was defective. He pushed it and it worked right away. I felt a little silly! It takes a lot more to push this one than it did on my Bold 9000.
    Someone mentioned somewhere that it's a 2-part push on the convenience key..i guess to utilize the focus function with the camera. Much like on a normal camera, a half push to focus, and a full push to snap the pic. I haven't even tried the camera out yet, but yes, i agree it does take a little more effort to push it than other convenience keys.

    I wish you could actually utilize the "2 push" system for other functions..which would kind of replace not having a 2nd convenience key. Who knows..maybe in a future OS update we'll get that feature.
    10-03-10 10:01 AM
  12. cestlavie77's Avatar
    Someone mentioned somewhere that it's a 2-part push on the convenience key..i guess to utilize the focus function with the camera. Much like on a normal camera, a half push to focus, and a full push to snap the pic. I haven't even tried the camera out yet, but yes, i agree it does take a little more effort to push it than other convenience keys.

    I wish you could actually utilize the "2 push" system for other functions..which would kind of replace not having a 2nd convenience key. Who knows..maybe in a future OS update we'll get that feature.
    The 2-part-push makes sense as far as the camera goes. But for those of us who don't use it for the camera it'd be nice if we could use it for two separate functions as you said. I'm really missing the 2nd convenience key.
    10-03-10 10:42 AM
  13. pattste's Avatar
    I'm using a Torch on TELUS.

    1) I have a BlackBerry.net address and a GMail address. Both work fine.
    2) I did not do a restore. I reinstalled all apps one by one.
    3) No issue with the Browser..
    4) Performance is great, no lag, no hourglass.
    5) I had to do a battery pull once as the phone freezed after running Google Sync to restore my contacts. All contacts had been transfered correctly.
    6) Battery lasts much longer than the 8530's that I had before. Easily lasts through a day of heavy use and two days of normal use.
    7) No issue with the GPS. But Google Map with GPS will run down a battery really fast, this is true for every phone. I suspect points 6 and 7 are related.

    Sorry that you're having all those issues. I think the Torch is a fantastic device.
    10-03-10 11:47 AM
  14. Roadrunner604's Avatar
    Wow, thanks for the feedback everyone!
    From the sounds of it, I think the problem lies with my incompetence as opposed to the device!
    I'm tempted to do a full hard reset so that I can start from scratch ... without using the "restore" function on Desktop Manager.
    10-03-10 07:02 PM
  15. Renegade44's Avatar
    I got the torch today and when i try to add apps from appworld it will only let me download 32/620kb instead of the full app. I tried 9 apps and all the same. It stops downloading and then i get a message that says there was a problem during installation. Any ideas?
    10-03-10 11:49 PM
  16. Gelzz's Avatar
    I purchased the Torch the day after Launch Day for the Torch in Canada from the local Telus store. I have had it for just over 24 hours now and experienced a few issues:

    (1) My telus.blackberry.net email addresses could not be added to the device; a call to Telus technical support resolved this issue. Apparently there can only be one "email profile" on the Torch and I had messed it up by creating one for gmail and another for telus.blackberry.net email addy (kind of a weird explanation I know). The rep had to 'reset' my email settings.
    I'm sorry to hear you're having these issues. I got mine through Telus on launch day and its been perfect. Without getting into too much technical speak..I'd say bring that one back and get a fresh one!

    Posted from my CrackBerry at wapforums.crackberry.com
    @ Roadrunner - I had the same problem but I found out from Telusmobility.com/blackberryemail and I called CSR and transfered me to Technical assistance. They Fixed everything of me on my end. I say call back and BETCH !

    @Mikey - I do agree call back and BETCH slap some and get a new one. I got mine at Telus BestBuy and works Hells Fine for me.

    Hope you get everthing Sorted mate.
    10-04-10 07:19 AM
  17. Rickroller's Avatar
    I got the torch today and when i try to add apps from appworld it will only let me download 32/620kb instead of the full app. I tried 9 apps and all the same. It stops downloading and then i get a message that says there was a problem during installation. Any ideas?
    Hmm..interesting. I actually had this happen last night to me when I tried to download a couple apps off Appworld. It would get to about 70 or 80kb and then just sit there. I just chalked it up to bad connection since I was in a hotel in a small town.

    Maybe there's some issues with App world right now. Anyone else noticing anything?

    EDIT: Tried it again this morning at work and seems to be working fine. I dl'd two different apps from Appworld and they both work fine. Is it just me or does the Search function in Appworld suck a$$. You pretty much have to know the exact name of the app you're looking for or it won't find it. For example..i wanted the Score Mobile app. I typed in "score mobile" and nothing but a bunch of other "mobile" apps came up. So i typed in The Score..and finally half way down the page I found it. I guess because it's official name is ScoreMobile (with no spacings) it wouldn't find it. Anyways..I think their Appworld could use some work imo
    Last edited by Rickroller; 10-04-10 at 10:22 AM.
    10-04-10 09:01 AM
  18. Fnord's Avatar
    Wow, thanks for the feedback everyone!
    From the sounds of it, I think the problem lies with my incompetence as opposed to the device!
    I'm tempted to do a full hard reset so that I can start from scratch ... without using the "restore" function on Desktop Manager.
    Never recommended to transfer everything. Best best is to do a normal backup on the old device and then advanced restore on the new one - selecting only items like contacts, adress book, wifi profiles... Always re-install apps from scratch.
    10-04-10 01:13 PM
  19. lowelldogg's Avatar
    I just got my new BB torch on telus and am loving it. I did have a few issues initially but got them worked out with only a little stress.
    1- old apps reloaded from desktop manager didn't work, or kinda worked. Re-downloaded apps from app world and crackberry solved this as most apps have been updated for OS 6 and torch.
    2- I also had a problem with the E-Mail app syncing with my live hotmail, but its seemed to have fixed itself!
    3- battery doesn't seem any better than the Bold, but the torch charges way faster.
    4- desktop 6 seems hard to navigate and a little confusing, but haven't had much time to play with it.
    Overall I am impressed with the torch. Way better than the storm and as good and better than the bold. Definately the best blend of touch screan/trackpad/physical navigation.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-10 09:58 PM
  20. john85D's Avatar
    I also have a problem with my browser. I do have a telus torch but I had it unlocked and I'm using it in another network.

    It inconsistently works, I have also tried doing the service book transfer from my old bold but it's still the same. So far, whenever my browser stops working I do a battpull and it seems to get it going again. I haven't tried turning off the mobile connections, I'll try that the next time it happens again. What's strange is that I do have the Bolt browser and it does work all the time. Any help???

    Posted from my CrackBerry at wapforums.crackberry.com
    11-01-10 10:48 AM
  21. Cannon Cunningham's Avatar
    The touch screen quits working have to do battery pulls.Any acvice
    11-08-10 06:35 PM
LINK TO POST COPIED TO CLIPBOARD