1. peetie's Avatar
    I've had the Torch for ~1week, experimented with the camera then went to really use it tonight and the damn thing won't take a photo. Has this happened to anyone else and does anyone have suggestions for fixing it?
    12-24-10 08:56 PM
  2. Shodan775's Avatar
    I've had the Torch for ~1week, experimented with the camera then went to really use it tonight and the damn thing won't take a photo. Has this happened to anyone else and does anyone have suggestions for fixing it?
    I had this..I removed the battery, then removed the memory card. Turns out, my memory card got corrupted, so since I have an adapter for the micro SD, I plugged it in my computer and formatted and reinserted and my camera worked again. If you don't have the option to format it, just remove the micro SD card , put the battery back in and try and see if your camera works again by saving the pictures to the internal memory. If it can, then it's definitely your flash card acting up.
    Last edited by Shodan775; 12-24-10 at 09:16 PM.
    12-24-10 09:12 PM
  3. vailjo91's Avatar
    My suggestions would be take out the Micro SD do a battery pull and replace the Micro SD with a new one it sounds like you may of got something onto the card that you did not mean or want to. If this dose not work I would then suggest trying to see if there are any updates you may not have and conncet it to your desktop manager.
    12-24-10 09:22 PM
  4. tbonenga's Avatar
    this happens to me. when i open the camera everything looks fine but when i push the button nothing happens. it doesn't matter if i push the side button or the icon on the screen. it's done this to me about 3 times already. last time i did a battery pull and it still did it. it's very weird.
    12-25-10 12:38 AM
  5. xxxmerlinxxx's Avatar
    Wifes torch has this problem. We have gone through 2 replacements. The last one was working, but would stop playing any audio after a few hours but the camera worked everytime. Checked it out and it was running 141. Upgraded through desktop manager to 246. Audio alerts work but now the camera isn't taking photos. Seems 246 is the start of this problem. I had her phone running 337 and it still had camera problems. I will try the sd card format today. Hopefully that will work.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-26-10 08:06 AM
  6. Altarocks's Avatar
    This happens to me occassionally. Frustrating, no doubt. Like others have suggested, a simple battery pull seems to do the trick.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-26-10 09:28 AM
  7. cheflionfoot's Avatar
    Battery pull did the trick for me. It only freezed up once on me tho. Has been fine ever since.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-26-10 09:51 AM
  8. nwoods06's Avatar
    I'm having the same camera issues with my Torch and the call,menu,touchpad,escape, and end call keys stop working intermittently. Called AT&T about it after too many battery pulls, security wipes, and re-installing the software. They told me these were becoming "known issues" and the only thing they can do is give me a warranty exchange. This is my second Torch with the same issues. Good news is, after three exchanges, they'll send me a different phone. I'm thinking of jumping ship for the Iphone and that whole evil empire.
    12-26-10 08:50 PM
  9. danny595's Avatar
    I have been having the same problem. It seems like when I need to capture a photo right now it freezes. nothing works, after I do a battery pull everything goes back to normal. Very frustrating!! I hope it is just a software issue.
    12-26-10 10:54 PM
  10. xxxmerlinxxx's Avatar
    So the third torch we got the camera worked!! why, because it was the previous OS (.141 i think). But with that the sounds would stop working after a while and we would have to do a battery pull. So i upgraded to .246. Camera stops working after a while. So now do I send back another TOrch only to assume that every phone we get with .246 will have the camera issue. Im not sure but maybe it something with her data and .246 that dont like each other. .337 has the same problem, so Im hoping for a leak sometime soon.
    01-04-11 08:56 AM
  11. AcADIeN's Avatar
    Open Camera,
    Click the Menu Button,
    Go to Options,

    Store picture is set to what ? if it's On Device then it could be your OS, if it's on Media Card, plug your blackberry in your pc, if it only detect 1 removable drive, you sd card need a format, if you do see 2 drive, then I'm pretty sure it's OS related.
    01-04-11 09:26 AM
  12. homer1475's Avatar
    Ive used every OS since launch of .141 and currently .337 and a .337 hybrid. Camera has always worked on every one. I think you'll find its a corrupt media card. PLug in your phone to your pc, then drag and drop everything on the card to your pc. Format the card via the device, then drag everything back to the card. Should work after that.
    01-04-11 09:36 AM
  13. xxxmerlinxxx's Avatar
    I tried the media card thing. Backed it up, formatted it on the phone. same problem. Changed the location it was saving pictures to the in phone storage and still camera wouldnt start. Thing is I have had this problem with 3 other phones. Could it be some data setting that has carried over from her older blackberry? Ill try that tonight.
    01-05-11 09:54 AM
  14. LatinoLoco24's Avatar
    Same issues with my camera intermittently working. Let me know if anything you try helps. It works when it wants to...
    01-05-11 11:03 AM
  15. agirl65's Avatar
    Last night my camera said it wouldn't start until I closed another application. I don't have any add-on apps on my Torch yet, and I hit the BB button and the usual 5 things were open... Between this and it locking up, I'm not 100% digging my new Torch
    01-05-11 11:46 AM
  16. xxxmerlinxxx's Avatar
    I ran a security wipe and only restoring certain data from a backup. Two days later the camera will start, but not take a picture. So we are back to square one. The temporary fix, for now, is to set a scheduled reboot of the phone with Quickpull. Not really the fix I was looking for.
    01-08-11 11:01 AM