1. justineporter's Avatar
    My phones keyboard would stop working on me, and it would take a few battery pulls to get it working properly and then a few hours later it would stop working again, so I was told to do a security wipe, which I did. I backed up my things and restored them onto my phone.
    But now my camera isn't working I go into my camera from both convenience key and the camera option and all I have is a black screen.
    06-27-11 06:51 AM
  2. homer1475's Avatar
    Have you tried reinstalling the OS? Would be the first thing I would try when an issue keeps popping up after several battery pulls. If you have, It sounds like it may be the early onset of a device that got wet. Keyboard usually goes first, then random odd things stop working.
    06-27-11 07:08 AM
  3. justineporter's Avatar
    There hasn't been any water damage to my phone. And I have reinstalled the operating system. I did it this morning and still nothing.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-27-11 07:10 AM
  4. homer1475's Avatar
    Probably hardware failures then. If reinstalling the OS didn't fix it. Did you try it before restoring your backup? If it was me, I would make a backup via DM, wipe with a program such as bbsak or jl_cmder, then reload the OS, and then try everything before restoring the backup. Could be something in your backup(odd setting, app perhaps?).

    It doesn't take much water for there to be water damage. Just sitting in your bathroom when your taking a shower is all it takes. Not saying this is definitely your issue, just that it could be a possible reason.
    06-27-11 07:15 AM
LINK TO POST COPIED TO CLIPBOARD