1. neonwut's Avatar
    Hey, anyone here know what i can do? every button on my torch just died, nothing works... the phone will still light up when i slide the screen open... and the touchscreen works fine, just no buttons... ive tried 2 battery pulls, same thing. any ideas? phone wasnt dropped or anything, i just answered a text, closed the phone, a minute later slid it open to answer another message and found the keys didnt work. Thanks in advance!
    01-26-11 07:57 PM
  2. skwij's Avatar
    Same happened to me a couple of times, immediately after being out in the COLD.

    Hasn't done it in ages but I still got a replacement through warranty. We shall see if the replacement does the same thing. I hope not.

    BTW with the original one, it took 2-3 battery pulls back to back to get it working again.
    01-26-11 10:34 PM
  3. neonwut's Avatar
    tried a half dozen pulls, same thing... tried putting .337 on, nothing. oh well... called em up, gettin another one in a few days... sucks!
    01-27-11 06:00 PM