1. RichardBlythe's Avatar
    I'm trying to get internet access on my 9800 browser with a WPA encrypted network. I can "connect" to the network but the browser will load any pages!! It hangs up for about 5 seconds then shows this message: "Unable to find the requested server"

    The browser works just fine on an unsecure connection. By the way I've tried WEP and WPA but none of them work.

    Can anyone help me resolve this?!!
    I've spent several hours of research and cannot find a solution.

    Thanks in advance,
    12-15-10 10:15 AM
  2. homer1475's Avatar
    What type of router? There have been a few posts about the torch not working on certain types of routers, mainly older d-links.
    12-15-10 10:24 AM
  3. chaddeus's Avatar
    I got my network set to WPA2 and connecting to the router is OK.. No problem

    - Charles
    12-15-10 10:37 AM
  4. papped's Avatar
    As said above probably a router compatibility or firmware issue. Both wep and wpa are fully supported and work.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-15-10 11:09 AM
  5. AcADIeN's Avatar
    I'm using linksys wrt54gl, a more recent wrt350N, dlink access point dwl 2100, and cisco spr500, all of them are using WPA and work fine with my phone. When you go in your Manage Connection do you see "ON" on the right of WI-FI or you see your wifi network name? because if you only see ON, it mean that it detect a signal, but can't do anything with it.
    12-15-10 11:28 AM
  6. RichardBlythe's Avatar
    Thanks for all the posts!

    It is a linksys router. Yes I can see the network name.
    Should I try to connect un-encrypted? My cousin lives next door and we are sharing the network. He owns the router and I don't want to put him out if it won't help the situation.

    (I'm fixing to do a google search on incompatible routers for the torch.)
    12-16-10 10:01 AM
  7. jcp007's Avatar
    I have a Linksys router. Ask your cousin for the password to link to the secure network connection. He is family after all.
    12-16-10 11:07 AM
  8. PatrickMJS's Avatar
    The router should work fine as long as you have entered the correct passphrase or encryption key. The error message you're getting may be the result of a weak signal. I've noticed my Torch doesn't do well if the wifi signal is 2 bars or less, and that is when I tend to get the "unable to find router" error message. I just added a range extender to my wifi-router and now it works very reliably.
    12-16-10 11:46 AM
  9. AmigaDude's Avatar
    Don't forget to add your Torch's mac address to the filter table, if it is turned on at the router. This is used frequently to only let known devices use the router.
    12-17-10 06:42 AM
  10. RichardBlythe's Avatar
    (Laugh) jcp007, I do have the password and ALL relevant data to connect to the network. Signal is strong, etc.

    I really feel like it's a router issue because I've been out of state and connected to open networks @ motels.
    12-17-10 12:57 PM