1. CellPhoneWizards's Avatar
    Hey all, i need a bit of help...

    I have a blackberry torch that i am fixing for a friend. Seems like he bricked it while trying to update it. The only life i get from the torch is there are a sequence of blinking red lights. 2 blinks, pause then 2 blinks. I've seen this on other phones but having some trouble.

    I tried jl commander but it does not do anything. must have tried it like 30 times with a battery pull before each try. Also tried AppLoader, but i get the device connected to the apploader software and try to connect and the devices disconnects from my pc by itself and apploader says connection failed!

    Maybe i am doing something wrong. My friend bought the phone second hand so there is no store he could take it to. Im sure the problem lies in my USB settings and could use some help!
    01-26-11 08:06 AM
  2. AcADIeN's Avatar
    here what you could try, remove the battery, plug the bb on your pc, open app loader, wait until it detect the device, press next (it will only detect for like 10 second, make sure you press next as soon as possible) then put your battery back in and install the OS. Every data on the phone will be gone though (well not what's on the sd card though)
    CellPhoneWizards likes this.
    01-26-11 08:20 AM
  3. jwhelan's Avatar
    Hopefully this link helps:

    KB10938-"USB charging current is insufficient" appears on the BlackBerry smartphone

    Under Cause 5:
    Turn off Power Management by completing the following steps:

    On the computer, click Start > Settings > Control Panel > System. The Systems Properties screen appears.
    On the Hardware tab, click Device Manager. The Device Manager screen appears.
    Double-click Universal Serial Bus controllers. The expanded USB list appears.
    Right-click USB Root Hub and click Disable.
    Double-click USB Root Hub. The USB Root Hub Properties screen appears.
    On the Power Management tab, clear the Allow the computer to turn off this device to save power option on all root hubs.
    Click OK.
    CellPhoneWizards likes this.
    01-26-11 08:45 AM
  4. CellPhoneWizards's Avatar
    still the same thing happens. I am running win 7 if that has anything to do with it...

    Also when i try to connect the AppLoader to the Torch, the Red light stops blinking and it disconnects from the computer. after the error comes up it connects again!

    AcADIeN, i can see what your saying but it still disconnects. I can have the blackberry plugged in the whole time and it will show the USB: PIN UNKNOWN untill i 1) unplug the device or 2) click next to where it says connecting to device then like 5 sec later the blackberry disconnects and the connections fails.
    Last edited by CellPhoneWizards; 01-26-11 at 09:06 AM. Reason: Added more info
    01-26-11 09:00 AM
  5. AcADIeN's Avatar
    when you click next, did you put the battery back in ? because without battery, your device will go on and off every 10 second, that's why I said you have to be quick, so as soon as you click Next (when it detect a usb device) put your battery in very fast.
    01-26-11 09:35 AM
  6. CellPhoneWizards's Avatar
    i did, could it be a bad battery???
    01-26-11 09:41 AM
  7. AcADIeN's Avatar
    did you said that it was your friend torch, and you have one yourself? maybe you could try your battery in your friend bb.

    If the battery is dead it could cause that problem.
    01-26-11 10:49 AM
  8. CellPhoneWizards's Avatar
    cool, ill try the battery and see if its the problem. then try to install the OS. Thanks for the help all, ill see what happens...
    01-26-11 10:56 AM
  9. pbflash's Avatar
    I had a similar problem when I was updating to the last leak with apploader. Try opening desktop manager and once it detects the phone, open apploader and try to update the OS.
    CellPhoneWizards likes this.
    01-26-11 12:46 PM
  10. Iatemyshorts's Avatar
    Happened to my girlfriend's Curve once while loading a new OS, I just kept trying with AppLoader, BBSAK, BBMCP, DM6 and nothing worked. Was about to give up but then I plugged the Curve into another USB port and it started installing the BB Drivers again and it worked O.O Loaded up Apploader and managed to get the phone working again.. No idea if it was a random chance or maybe the drivers or USB port screwed up. Try removing the drivers and let them install again?
    01-26-11 08:08 PM
  11. CellPhoneWizards's Avatar
    ok, i have 3 ports on my laptop and none of them worked. i have a freshly charged battery out of another torch in it and still nothing. Every time i open apploader and click next the damn torch just disconnects from the computer...
    01-26-11 08:27 PM
  12. pbflash's Avatar
    Did you try my suggestion?
    01-26-11 10:09 PM
  13. cyphon21's Avatar
    Does BBSAK detect it? Thats the #1 solver for all my BB issues!
    CellPhoneWizards likes this.
    01-26-11 10:17 PM
  14. CellPhoneWizards's Avatar
    I tried all those programs, BBSAK, MCP, Download Manager, AppLoader... None of them detect the device except apploader and after i try to connect on apploader the bb disconnects and fails.
    01-27-11 06:54 AM
  15. CellPhoneWizards's Avatar
    ok update. I tried doing the same on my desktop running win xp. same thing. connects, shows USB-PIN: UNKNOWN, click next then the Blackberry disconnects from the computer, Apploader fails to connect and then the Blackberry connects back to the computer... im about to tell my friend to take an Axe to the torch!

    ADD: is there any more settings to get this damn thing to stop disconnnecting while apploader connects?
    01-27-11 09:25 AM
LINK TO POST COPIED TO CLIPBOARD