1. junhowong's Avatar
    Every time I pull out and switch batteries on this thing, I lose 3G connection! I can't bbm or surf. I tried pulling the battery again, disconnected the mobile network many times, STILL NO HELP! the only way I found working was security wiping.... PLEASE HELP!
    10-08-10 02:12 AM
  2. Masahiro's Avatar
    With universal search, look up "Host Routing Table" under system options (there should be only one). Open the options menu once inside and click on "Register Now". Can't think of anything else at the moment, other than calling into Bell.
    10-08-10 02:14 AM
  3. anoxia187's Avatar
    does ur phone go to edge in small letters ? call bell to double check if your data plan was changed ?
    10-08-10 03:00 AM
  4. junhowong's Avatar
    I just tried it didn't work thanks though
    10-08-10 03:04 AM
  5. junhowong's Avatar
    no i'm with bell... lol it's just 3G
    10-08-10 03:05 AM
  6. anoxia187's Avatar
    no i'm with bell... lol it's just 3G
    forgot bell doesnt have edge lol. different network haha. Take the phone back to where you purchased it or call tech support to reload software.
    10-08-10 03:57 AM
LINK TO POST COPIED TO CLIPBOARD