1. Massimiliano Giuffrida's Avatar
    Hello everyone!!! i have a blackberry 9800, and it used to be locked, so i went into Blackberry Unlock Codes - #1 Source for FREE Unlock Codes and got my mep2 code for free... i turned off all conections, went to settings, device, sim card, wrote mep, then mep2 and introduced the code....just as expected, now everythings says disabled, it means my 9800 should be unlocked....well, the problem is that it only works with the one sim card it had inside when i did this.... ive tried with many... including a couple from the original provider and nothing...it says "insert sim card"and "sos", i even changed the sim card slot...just in case... y wiped the phone, reinstalled OS...I dont know what else to do...if anyone has an idea please tell me! thanx for ur time
    03-08-14 09:19 PM
  2. MiSsY_'s Avatar
    Does it work with a SIM card from the carrier it is locked to?
    03-09-14 10:57 AM
  3. Massimiliano Giuffrida's Avatar
    nop, surprisingly it works with a sim from a different carrier...its just crazy
    03-10-14 10:00 AM
  4. JP82191's Avatar
    Maybe the sim card is dead?

    Sent From The Almighty Z10
    03-10-14 10:01 AM
  5. masterscarhead1's Avatar
    Try a couple other SIM cards. I think you may have either faulty sim cards or inactive sim cards
    03-10-14 10:56 AM
  6. Massimiliano Giuffrida's Avatar
    as i said ive tried many...that includes mine as well...the one i use in my current phone that works perfectly!! just to be clear im from venezuela and the carriers are movistar,movilnet, and digitel, ive tried whit 3 from digitel, 2 from movistar and 3 from movilnet, and there is on currently being used from each... so the sims are not an issue...
    i think something went wrong at the moment i entered the mep2 code...cuz thats when it stop working, but i cant undo what i did, can i?
    thanx for your time and answers
    03-10-14 10:57 PM
  7. JP82191's Avatar
    Did you do a battery pull after the unlock? Did you re download service books specific from each carrier?

    If not re lock the carrier subsidy. Pull battery. Check status. Unlock it and pull battery.

    Sent From The Almighty Z10
    03-11-14 12:44 AM
  8. mekanwoshu's Avatar
    that right,I think you may have either faulty sim cards or inactive sim cards ,thanks
    03-11-14 04:12 AM
  9. Massimiliano Giuffrida's Avatar
    ok ok thats new...lets work with it..how do i re lock the carrier? (when i go to settings/device/advanced/sim card and i write mep and then mep2 nothing happens so i dont know how to relock it and re unlock it after!so if possible...walk me through! and thanks for the idea!!!
    03-11-14 01:17 PM
  10. JP82191's Avatar
    Don't you hit the menu and select enable? I don't have a legacy device anymore so I don't remember the exact steps.

    Sent From The Almighty Z10
    03-11-14 10:53 PM

Similar Threads

  1. Yup, Picked up my first Playbook. University needs
    By Dennings83 in forum BlackBerry PlayBook
    Replies: 14
    Last Post: 04-24-14, 09:33 PM
  2. Plz someone tell me what's RIM in BlackBerry?
    By Vaibhav Pawar in forum BlackBerry 10 OS
    Replies: 23
    Last Post: 03-10-14, 03:45 PM
  3. SNL disses BlackBerry
    By cadiraim in forum General BlackBerry News, Discussion & Rumors
    Replies: 22
    Last Post: 03-09-14, 11:21 PM
  4. Weird issue with site load - Verizon
    By RJanney in forum BlackBerry Z10
    Replies: 2
    Last Post: 03-09-14, 01:32 PM
  5. Latest Saturday Night Live "Weekend Update" dissing Blackberry
    By vincentkong in forum General BlackBerry News, Discussion & Rumors
    Replies: 5
    Last Post: 03-09-14, 04:46 AM
LINK TO POST COPIED TO CLIPBOARD