1. anon2100101's Avatar
    Some themes dont support the media-tab in the OS6 UI. That seems to be a generaly problem beside the bugs you have to accept, when a theme is created with the current beta-version of the Theme Builder... Here now a nearly reliable solution:

    Make sure, that your software is latest (6.0.033X).

    Open your appscreen and open also the menu. Take care that NO icon/trigger is hidden; make them all visible.
    Look for a folder which named exactly (!!!)

    net_rim_bb_file_explorer.Media

    If you dont find this file create this folder with exactly (!!!) this name (the "M" in Media must be capital!!!)

    Then shift all the media-icons (Ringtone, music etc.) into this folder.

    Now hide this folder (and all the other folder/icons you dont want to see) again and make a reboot (battery pull)

    After this happens you should find the media icons under the media-tab/header! :-)

    If you want to held the official Media-Folder on your appscreen and you are unlucky to have it (now) empty, you could shift the three supplementary icons (which appears when you unhide all icons/folder) for music, video and pics into it... :-) Otherwise you can hide also the media-folder...

    AlKa and sommerface like this.
    01-27-11 01:31 AM
  2. anon2100101's Avatar
    BTW- I would be glad, if some feetbacks (and/or thanks) would hold this threat for a while on the first side cause I think, that a lot of Torch-User have this problem... :-)
    1425956 likes this.
    01-27-11 01:47 AM
  3. AxKxB's Avatar
    This post was urgently required! Glad you took the intiative! cheers!!
    anon2100101 likes this.
    01-27-11 07:55 AM
  4. anon2100101's Avatar
    You are my inspiration and mentor...! :-)
    01-27-11 09:13 AM
  5. KahneFan's Avatar
    I have seen many tips about TB6, it would be great if there was a TB6 tips/tricks thread where they were all together. TB6 doesn't work on my Vista machine, but if I ever get a 7 machine I will definitely give this a shot.
    01-27-11 10:21 AM
  6. StaticFX's Avatar
    another tidbit... for those that like to tamper with the SVG in theme building.

    this is a way to have shortcuts to folders

    in the <loadscene> code... use net_rim_bb_file_explorer.XXXXX
    where XXXXX is the name of the folder. Since you cant select a folder as an icon.. you would use this instead.

    Like
    net_rim_bb_file_explorer.Media
    net_rim_bb_file_explorer.Applications
    net_rim_bb_file_explorer.Games

    etc I discovered this when doing my DashBoard theme.. I wanted a shortcut to all media.. not just music etc

    have fun!
    anon2100101 likes this.
    01-27-11 10:30 AM
  7. anon2100101's Avatar
    Thank you very much,StaticFX...!!!!

    Posted from my CrackBerry at wapforums.crackberry.com
    01-27-11 01:17 PM
  8. StaticFX's Avatar
    youre welcome.. took a good few hours of tinkering and then found it accidentally! lol
    01-27-11 01:21 PM
  9. ehard24's Avatar
    When u say "appscreen" do u mean the "ALL" tab on the OS6 UI?
    01-27-11 02:40 PM
  10. anon2100101's Avatar
    Yes, I do... The mainscreen under the "all"header...

    Posted from my CrackBerry at wapforums.crackberry.com
    01-27-11 03:07 PM
  11. ehard24's Avatar
    That worked perfect! I saw a folder like that a while back and wondered what it was. Also, where do you get your wallpapers? You got some nice uns!
    01-27-11 09:27 PM
  12. anon2100101's Avatar
    Unfortunately Im not a themebuilder and/or wallpapermaker* (*or just very amateurish)... Im a more patient sponger who stores everything he can ascertain...:-) My knowledge is the result of monitoring with passion...

    For the best walls in this forum go to the "God of walls" sunny...:-)

    http://forums.crackberry.com/f123/bb...20x240-471356/

    Some are selfmade, others are collected from countless web-sides I visit... :-)
    01-28-11 01:01 AM
  13. BBThemes's Avatar
    OR how about this, the REAL fix for the media tab, its simple and requires no works at all from the end user.

    developers, DO NOT add links to websites in OS6 UI themes, this and this alone is what breaks the tabs. nothing else.

    if you have added a link, you`ll need to recreate the theme from scratch to fix (perfect timing with Beta2 being out now)

    so there ya all go, no more BETA bug BS, its the devs that add links that break it (although is RIM`s fault, not the devs) and nothing else, you`ll still need to reboot when you`ve downloaded, but THIS is how to not break the themes.
    JaimemarieG likes this.
    01-28-11 01:21 AM
  14. anon2100101's Avatar
    I will post some of my (collected) walls...:-)









    01-28-11 01:28 AM
  15. anon2100101's Avatar
    01-28-11 01:31 AM
  16. AxKxB's Avatar
    Thank you sfx!

    @BBthemes: Glad you shared this info about how to avoid this particular tb6b glitch (or in your words 'RIMS fault') with all of us at this point!

    However, the above mentioned is a solution for those who ARE facing the problem with the themes that they are using at the moment and most OS6UI themes seem to be presenting this error!
    anon2100101 likes this.
    01-28-11 03:01 AM
  17. BBThemes's Avatar
    However, the above mentioned is a solution for those who ARE facing the problem with the themes that they are using at the moment and most OS6UI themes seem to be presenting this error!
    very true, also worth noting is that rebuilding in tb6 BETA2 will also fix the banner in landscape and the images on lockscreen too
    01-28-11 02:19 PM
  18. anon2100101's Avatar
    I've heard that the current beta version of TB6 will fix a lot of bugs..... And so this thread becomes hopefully unnecessary...:-)

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-11 09:20 AM
  19. anon2100101's Avatar
    Reminder!!!!

    Posted from my CrackBerry at wapforums.crackberry.com
    02-05-11 12:26 PM
  20. BBThemes's Avatar
    I've heard that the current beta version of TB6 will fix a lot of bugs..... And so this thread becomes hopefully unnecessary...:-)

    Posted from my CrackBerry at wapforums.crackberry.com
    sadly the issue still exists with the Beta2, however i hope me putting the root cause of the issue on here will of helped some devs
    02-06-11 12:28 PM
  21. JaimemarieG's Avatar
    OR how about this, the REAL fix for the media tab, its simple and requires no works at all from the end user.

    developers, DO NOT add links to websites in OS6 UI themes, this and this alone is what breaks the tabs. nothing else.

    if you have added a link, you`ll need to recreate the theme from scratch to fix (perfect timing with Beta2 being out now)

    so there ya all go, no more BETA bug BS, its the devs that add links that break it (although is RIM`s fault, not the devs) and nothing else, you`ll still need to reboot when you`ve downloaded, but THIS is how to not break the themes.

    I tested this out, and did a minimal changes, as in a color change for focus caret. I did not add a link and the Media Tab issue was still present. I am using the Beta2.
    I tried this several times.

    So I would say its not a valid fix for ALL.. maybe works for some, but not all.

    However thank you for this. I will keep trying this process out when i make myself themes.
    02-08-11 02:39 PM
  22. ThisIzLife's Avatar
    I would really like to try this out but not sure what you mean by going to "Open your appscreen and open also the menu" where do i find this on my bold 9700 running os 6.. thank u
    03-11-11 03:17 PM
  23. ThisIzLife's Avatar
    That worked perfect! I saw a folder like that a while back and wondered what it was. Also, where do you get your wallpapers? You got some nice uns!
    Did you do this fix from ur phone? and if so where is "Open your appscreen and open also the menu" thanks
    03-11-11 03:33 PM
LINK TO POST COPIED TO CLIPBOARD